SiT! Bugs - SiT!
View Issue Details
0001029SiT!LDAPpublic2010-01-07 17:472010-01-23 19:02
donchucho 
paulh 
normalminoralways
closedfixed 
3.50 
3.513.51 
0001029: ALWAYS SET DEFAULT SITE TO CONTACTS
I have created 3 sites and y enabled ldap autentication, when a ldap contact log in, his site is modified by the default site especified in control panel -> configure -> LDAP
No tags attached.
Issue History
2010-01-07 17:47donchuchoNew Issue
2010-01-07 20:47donchuchoNote Added: 0002252
2010-01-07 20:53donchuchoNote Edited: 0002252bug_revision_view_page.php?bugnote_id=2252#r55
2010-01-08 13:46donchuchoNote Edited: 0002252bug_revision_view_page.php?bugnote_id=2252#r56
2010-01-09 13:00paulhNote Added: 0002257
2010-01-09 13:00paulhAssigned To => paulh
2010-01-09 13:00paulhStatusnew => resolved
2010-01-09 13:00paulhResolutionopen => fixed
2010-01-09 13:00paulhFixed in Version => Current SVN
2010-01-09 13:00paulhTarget Version => 3.50p1
2010-01-23 19:01ivanFixed in VersionCurrent SVN => 3.51
2010-01-23 19:02ivanNote Added: 0002305
2010-01-23 19:02ivanStatusresolved => closed

Notes
(0002252)
donchucho   
2010-01-07 20:47   
(edited on: 2010-01-08 13:46)
i just comment the line 412 of the file lib/ldap.inc.php and works fine for me.

//$contact->siteid = $CONFIG['ldap_default_customer_siteid'];

(0002257)
paulh   
2010-01-09 13:00   
Hi, r5981 to the 3.x and trunk banches resolves this issue by only setting the siteid on initial import
(0002305)
ivan   
2010-01-23 19:02   
Fix released in v3.51 which is now available