SiT! Bugs - SiT!
View Issue Details
0001123SiT!authenticationpublic2010-03-06 11:262015-04-20 13:19
ivan 
paulh 
normalminorhave not tried
resolvedfixed 
3.51 
4.0Current GIT 
0001123: Trusted server mode broken
The config option 'trusted_server' claims that passwords will no longer be required with this enabled. However I don't think this has worked in a long time, the feature hasn't been maintained.

We should probably remove this for 3.60 and discuss whether to keep the feature in the long term (4.x and beyond).
No tags attached.
Issue History
2010-03-06 11:26ivanNew Issue
2010-03-06 15:29ivanNote Added: 0002610
2010-03-06 15:29ivanStatusnew => assigned
2010-03-06 15:29ivanAssigned To => ivan
2010-03-06 15:33ivanNote Added: 0002611
2010-03-06 15:33ivanTarget Version3.60 LTS => 4.0
2011-02-14 13:25ivanTarget Version4.0 => 3.90beta1
2011-05-21 10:47ivanAssigned Toivan =>
2011-05-21 15:31ivanStatusassigned => acknowledged
2011-06-03 22:20ivanNote Added: 0003821
2011-06-03 22:20ivanTarget Version3.90beta1 => 4.0
2015-04-19 20:11paulhAssigned To => paulh
2015-04-19 20:11paulhStatusacknowledged => assigned
2015-04-20 13:19paulhNote Added: 0004962
2015-04-20 13:19paulhFixed in Version => Current GIT
2015-04-20 13:19paulhStatusassigned => resolved
2015-04-20 13:19paulhResolutionopen => fixed

Notes
(0002610)
ivan   
2010-03-06 15:29   
All the trusted_server option does right now is prevent passwords from being changed in the user profile. For 3.x I'm going to change the help on the config option but leave the option there.
(0002611)
ivan   
2010-03-06 15:33   
Reworded in svn r6201 for 3.x, a decision still needs to be made for 4.x
(0003821)
ivan   
2011-06-03 22:20   
Decision not made yet and feature freeze for 3.90 happened now, deferring until 4.0
(0004962)
paulh   
2015-04-20 13:19   
1df2703 adds in this functionality