SiT! Bugs - SiT!
View Issue Details
0001394SiT!feedbackpublic2010-09-06 15:472011-07-17 13:09
sanchezpaa 
paulh 
lowblockalways
closedfixed 
LinuxLinux2.6+later
3.62 LTS 
3.63 LTS3.63 LTS 
0001394: Can´t browse feedback
When trying to browse feedback I get the following error:
Application Warning [512]
Column 'created' in order clause is ambiguous in /opt/lampp/htdocs/sit/feedback_browse.php @ line 185
Backtrace:
/opt/lampp/htdocs/sit/feedback_browse.php @ line 185 trigger_error()
No tags attached.
Issue History
2010-09-06 15:47sanchezpaaNew Issue
2010-09-06 20:25TomseNote Added: 0003401
2010-09-06 20:25TomseStatusnew => feedback
2010-09-06 21:37sanchezpaaNote Added: 0003402
2010-09-06 21:37sanchezpaaStatusfeedback => new
2010-09-21 20:59paulhNote Added: 0003412
2010-09-21 20:59paulhStatusnew => feedback
2010-11-30 20:39paulhStatusfeedback => assigned
2010-11-30 20:39paulhAssigned To => paulh
2010-11-30 20:40paulhNote Added: 0003484
2010-11-30 20:49paulhNote Added: 0003485
2010-11-30 20:49paulhStatusassigned => resolved
2010-11-30 20:49paulhResolutionopen => fixed
2010-11-30 20:49paulhFixed in Version => Current SVN
2010-11-30 20:49paulhTarget Version => 3.63 LTS
2011-04-16 15:07ivanNote Added: 0003710
2011-04-16 15:07ivanStatusresolved => closed
2011-07-17 13:09ivanFixed in VersionCurrent SVN => 3.63 LTS

Notes
(0003401)
Tomse   
2010-09-06 20:25   
I'm not able to reproduce your problem.

you need to supply more details on how to repro the problem.
(0003402)
sanchezpaa   
2010-09-06 21:37   
I have no idea how to reproduce the problem. I fixed it by adding ff in front of `created` in line 181 of feedback_browse.php

                default:
                    $sql .= " ORDER BY ff.created DESC";
                    break;
(0003412)
paulh   
2010-09-21 20:59   
Hi,

I've just reviewed the code and given the error your seeing I'd expect to see a field called created in both feedbackforms and feedbackformsresponded except the field in feedbackforms is named createdby, can you check your schema and see if feedbackforms does have a column named created (if it doesn't I'm uncertain where it came from).

Cheers
Paul
(0003484)
paulh   
2010-11-30 20:40   
Looking though the scheme I've managed to identify why this happens

the new create schema doesn't have a created on dbFeedbackForms but their is an alter from 23Apr2008
(0003485)
paulh   
2010-11-30 20:49   
r6768 and ef30df8 resolve this
(0003710)
ivan   
2011-04-16 15:07   
Fix Released in 3.63