SiT! Bugs - SiT!
View Issue Details
0001500SiT!portalpublic2011-04-29 21:522011-06-18 17:51
Tomse 
ivan 
normalminoralways
resolvedfixed 
BSDFreeBSD6.4+Later
3.63p1 
3.90beta1Current GIT 
0001500: portal kbarticle.php doesn't have a menu bar
portal kbarticle.php doesn't have a menu bar
No tags attached.
Issue History
2011-04-29 21:52TomseNew Issue
2011-04-30 17:42paulhNote Added: 0003765
2011-04-30 17:42paulhStatusnew => acknowledged
2011-06-15 17:46ivanNote Added: 0004008
2011-06-15 17:46ivanStatusacknowledged => confirmed
2011-06-15 17:47ivanTarget Version => 3.90beta1
2011-06-18 17:50ivanAssigned To => ivan
2011-06-18 17:50ivanStatusconfirmed => assigned
2011-06-18 17:51ivanNote Added: 0004050
2011-06-18 17:51ivanStatusassigned => resolved
2011-06-18 17:51ivanFixed in Version => Current GIT
2011-06-18 17:51ivanResolutionopen => fixed

Notes
(0003765)
paulh   
2011-04-30 17:42   
This only happens if you have $CONFIG['portal_kb_enabled'] set to public as we don't enforce authentication in this case.

This was by designed, though I can see its possibly confusing, its been like this for along time. Not sure if we want to change?
(0004008)
ivan   
2011-06-15 17:46   
When viewing the public KB there's no link to return to the login page so I think at least for that function there should be a menu bar.

When viewing the KB from within the portal when the public KB is enabled I think we need to show the portal menu. I realise that will make some complex code probably, but as a user thats what i'd expect to happen.
(0004050)
ivan   
2011-06-18 17:51   
Fixed in Git 096d317