SiT! Bugs - SiT!
View Issue Details
0001823SiT!outbound emailpublic2012-12-06 21:302013-07-06 17:22
ringram74 
paulh 
normalminoralways
resolvedfixed 
LinuxLinux2.6+later
3.67 LTS 
3.68Current SVN 
0001823: First response email has slash in subject if incident was generated by incoming email with quote (') in subject
When an incident is generated from an incoming email and that email has a quote in the subject line, the first response email will contain the escape slash in the subject line. For instance, if you send an email to the support inbox for SiT with a subject of "Help needed with Russ's computer!", when the incident gets assigned to an engineer and an email is triggered, that outgoing email with have a subject of "[1] Help needed with Russ\'s computer!". The slash isn't there in the ticket title in the web interface, however.
Have SiT configured to check an email inbox.
Send email to the support inbox with a quote in the subject line
Assign the incident that was generated from your email to user
I'm running SiT v3.67p1 on CentOS 6.3 with PHP 5.3.3 with a MySQL 5.1.66 backend.
No tags attached.
Issue History
2012-12-06 21:30ringram74New Issue
2012-12-06 23:40FlyingScotsmanNote Added: 0004608
2012-12-06 23:42ringram74Note Added: 0004609
2013-01-20 12:54paulhNote Added: 0004658
2013-01-20 12:54paulhStatusnew => confirmed
2013-02-03 11:52ivanNote Added: 0004660
2013-02-03 15:12paulhAssigned To => paulh
2013-02-03 15:12paulhStatusconfirmed => assigned
2013-02-03 15:12paulhNote Added: 0004662
2013-02-03 15:25ivanNote Added: 0004670
2013-02-04 19:36paulhNote Added: 0004690
2013-02-04 19:36paulhStatusassigned => resolved
2013-02-04 19:37paulhResolutionopen => fixed
2013-02-04 19:37paulhFixed in Version => Current SVN
2013-07-06 17:22ivanTarget Version => 3.68

Notes
(0004608)
FlyingScotsman   
2012-12-06 23:40   
Shouldn't the category be inbound email?
(0004609)
ringram74   
2012-12-06 23:42   
No. The inbound email is handled correctly by adding the slash so it goes into the database properly. The outbound email should be removing the slash and is not.
(0004658)
paulh   
2013-01-20 12:54   
Can reproduce this, as ringram74 says this only affects the welcomeing email sent by the triggers, the web interface and subsequent emails are OK
(0004660)
ivan   
2013-02-03 11:52   
I think commit f8d33900 in Git fixes this. Need to check.
(0004662)
paulh   
2013-02-03 15:12   
I'll check with my test system when I can back to a machine which can route email
(0004670)
ivan   
2013-02-03 15:25   
Also committed in the 3.x branch svn 7564
(0004690)
paulh   
2013-02-04 19:36   
can confirm Ivans previous fixes resolves this issue