SiT! Bugs - SiT!
View Issue Details
0000008SiT!dashboardpublic2008-07-11 15:322009-08-16 14:38
administrator 
ivan 
hightweakalways
closedfixed 
Internet ExplorerWindows
3.35 
3.503.50 
0000008: Dashlet reordering broken in IE
Dashlet reordering broken in IE Private: (?)
No
Attempting to reorder dashlets in IE 6 triggers a popup error:

"A Runtime Error has occurred. Do you wish to Debug?

Line: 3546
Error: Invalid argument"

Similar behaviour occurs in IE 7 but I believe there is no popup then (this
may be due to individual browser settings)
Date: 2008-07-04 14:30
Sender: ivanlucasProject Admin
Logged In: YES
user_id=1456679
Originator: NO

I've put a check for IE into the drag/drop code, dragging/dropping the
dashlets now simply does not work in IE rather than producing an error, a
mild improvement perhaps.

I've also changed the add dashlet code so that dashlets are added to empty
columns rather than always the left column, this does improve things for IE
users a little bit.

Expect a better solution in a release after 3.35.
                            

Date: 2008-05-30 16:01
Sender: ivanlucasProject Admin
Logged In: YES
user_id=1456679
Originator: NO

According to the rather awful Microsoft Script Debugger the error is in
dojo.js at the fifth line shown below:

if(this.methodfunc){
_33b=this.object[this.methodname].apply(this.object,args);
}
}
}
catch(e){
if(!this.squelch){
dojo.debug(e,"when calling",this.methodname,"on",this.object,"with
arguments",args);


Yes thats right a closing bracket.. I'm really not sure whats causing this
and don't have time to sort it before the 3.35 release unfortunately. For
the release after 3.35 I'll try and replace the dojo drag and drop with
something better.

The work-around for now is to use a better browser like Firefox or Opera.
                            

Date: 2008-05-15 12:32
Sender: ivanlucasProject Admin
Logged In: YES
user_id=1456679
Originator: NO

Thanks for the bug report. I've just tried it and I can confirm this bug
with IE6 and the current svn version. The line number I get is 3547, I
guess it moved slightly in the svn version.

I'll have a look into this and try to fix it before we release 3.35
                            
No tags attached.
related to 0000486closed ivan Dashboard uses dojo 
Issue History
2008-07-11 15:32administratorNew Issue
2008-07-11 15:32administratorStatusnew => assigned
2008-07-11 15:32administratorAssigned To => ivan
2008-10-22 23:44kieranNote Added: 0000128
2009-03-11 16:57ivanRelationship addedrelated to 0000486
2009-03-11 16:58ivanNote Added: 0000773
2009-03-11 16:58ivanStatusassigned => resolved
2009-03-11 16:58ivanResolutionopen => fixed
2009-03-11 16:58ivanFixed in Version => Current SVN
2009-03-11 16:58ivanTarget Version => 3.50
2009-08-16 13:17ivanFixed in VersionCurrent SVN => 3.50
2009-08-16 14:38ivanNote Added: 0001617
2009-08-16 14:38ivanStatusresolved => closed

Notes
(0000128)
kieran   
2008-10-22 23:44   
Any chance of this getting in for 3.40? If not can we target for 3.45 (maybe even 3.41 as it's a bug fix?)
(0000773)
ivan   
2009-03-11 16:58   
Fixed in trunk svn r5244. Tested in IE7.
(0001617)
ivan   
2009-08-16 14:38   
Released in 3.50rc1