SiT! Bugs - SiT!
View Issue Details
0000911SiT!sites & contactspublic2009-08-27 11:032010-03-01 09:50
sancho78rus 
 
normalminoralways
closedfixed 
3.50 
3.51 
0000911: Bad symbols in contact's notes
like ?????????? in russian
No tags attached.
png notes_chars_russian_japanese.png (39,644) 2009-08-27 13:38
http://bugs.sitracker.org/file_download.php?file_id=61&type=bug
png
Issue History
2009-08-27 11:03sancho78rusNew Issue
2009-08-27 11:51ivanNote Added: 0001841
2009-08-27 11:51ivanStatusnew => confirmed
2009-08-27 11:51ivanProduct Version => 3.50
2009-08-27 11:52ivanSeveritymajor => minor
2009-08-27 11:58ivanNote Added: 0001842
2009-08-27 13:36ivanNote Added: 0001851
2009-08-27 13:36ivanStatusconfirmed => feedback
2009-08-27 13:38ivanFile Added: notes_chars_russian_japanese.png
2009-08-27 13:42sancho78rusNote Added: 0001852
2009-08-27 13:51ivanNote Added: 0001853
2009-08-27 14:00sancho78rusNote Added: 0001854
2009-08-27 14:06ivanNote Added: 0001855
2009-08-27 14:14sancho78rusNote Added: 0001857
2009-08-27 14:21ivanNote Added: 0001859
2009-08-27 14:25sancho78rusNote Added: 0001860
2009-08-27 14:32ivanNote Added: 0001861
2009-08-27 14:40ivanNote Added: 0001862
2009-08-27 14:46sancho78rusNote Added: 0001864
2009-08-27 14:55ivanNote Added: 0001865
2009-08-27 17:45ivanNote Added: 0001871
2009-09-17 13:47sancho78rusNote Added: 0001973
2010-03-01 09:01sancho78rusNote Added: 0002553
2010-03-01 09:50ivanNote Added: 0002556
2010-03-01 09:50ivanStatusfeedback => closed
2010-03-01 09:50ivanResolutionopen => fixed
2010-03-01 09:50ivanFixed in Version => 3.51

Notes
(0001841)
ivan   
2009-08-27 11:51   
Thanks for the bug report, I can confirm this with 3.50rc1
(0001842)
ivan   
2009-08-27 11:58   
The same problem exists for site notes
(0001851)
ivan   
2009-08-27 13:36   
Hmm having said I can reproduce this, I can get strange results if I copy paste the test data at http://sitracker.org/wiki/Development/Test_Data [^]

But it works just fine with the Russian and Japanese Lorem Ipsum text on that page.

Can you try pasting the Russian text from that wiki page into a notes field to see what happens?
(0001852)
sancho78rus   
2009-08-27 13:42   
after changin cp to utf8 its ok.
but the problem with first letter search is still going on.
(0001853)
ivan   
2009-08-27 13:51   
Your existing data will now likely have the wrong character set. Try adding a new contact and trying the first letter search to find that contact.
(0001854)
sancho78rus   
2009-08-27 14:00   
no. with new clients and contacts - the same problem.

my date now must be in utf8. how i change cp:
1) export all base in txt file.
2) replace all cp1251 on utf8 in this file
3) delete sit db
4) create new sit db with utf8
5) make sql query from txt file.
all field now utf8 general_ci
(0001855)
ivan   
2009-08-27 14:06   
Hmm... I really can't reproduce this, is it possible that you could export, zip up and send me your database by email? (ivan [at] sitracker {dot} org) I will of course treat all information as confidential and delete it afterwards.
(0001857)
sancho78rus   
2009-08-27 14:14   
sent
(0001859)
ivan   
2009-08-27 14:21   
Thanks, I'm having difficulty importing the database into mysql without the encoding being wrong though. Do you know what encoding that text file has? When I look with phpmyadmin at what I've imported I just see ?????????? instead of russian text. :-(
(0001860)
sancho78rus   
2009-08-27 14:25   
hmmm. i just create this file in windows and ctrl-v data from phpmyadmin. there is no cp select when export
(0001861)
ivan   
2009-08-27 14:32   
ah I've figured I think, the charset is 8859-1. give me a few minutes to try this and I'll let you know what happens.
(0001862)
ivan   
2009-08-27 14:40   
I was wrong it wasn't 8859-1, I can't actually figure out how to decode that text. :( Can you try again to export.

* click on the database name in phpMyAdmin
* click the 'export' tab
* check the box 'save as file'
* select zip, gzip or bzip compression
* click go

And then email that file and I'll see if I can get anywhere with that. Thanks.
(0001864)
sancho78rus   
2009-08-27 14:46   
done
(0001865)
ivan   
2009-08-27 14:55   
ok, finally i reproduce it! :-) I'll now try and find out what is causing it. Thanks for your patience.
(0001871)
ivan   
2009-08-27 17:45   
Just to confirm? The original issue here, the bad symbols in the contacts notes... that is resolved now?
(0001973)
sancho78rus   
2009-09-17 13:47   
its ok now
(0002553)
sancho78rus   
2010-03-01 09:01   
you can close it now
(0002556)
ivan   
2010-03-01 09:50   
Fixed in or prior to 3.51. Thanks sancho78rus