SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001007SiT!incidentspublic2009-11-10 13:182010-01-23 19:02
Reporterpaulh 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.51Fixed in Version3.51 
Summary0001007: able to change the priority of an incident to one not defined at that SLA
DescriptionPossible to set a call to critical when the SLA doesn't support it

results in the following error on the incidents page

could not retrieve service level (SELECT * FROM `servicelevels` WHERE tag='SLA3000' AND priority='4' ) in /var/webtrack/inc/incidents_table.inc.php @ line 112 trigger_error() include()
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002149)
paulh (administrator)
2009-11-14 14:23

This problem is due to lines 382-386 of incident_update.php

// // FIXME fix maximum priority
// $servicelevel=maintenance_servicelevel(incident_maintid($id));
// if ($servicelevel == 2 || $servicelevel == 5) $maxpriority = 4;
// else $maxpriority = 3;
    $maxpriority = 4;

Will look at fixing this weekend
User avatar (0002150)
paulh (administrator)
2009-11-14 19:27

paulh@uist:~/git/sitracker$ git commit
[master 676df12] * Fix for being able to assign a priority to an incident whos SLA doesn't support it (Mantis 0001007)
 3 files changed, 48 insertions(+), 14 deletions(-)


need to push and move to sitracker3
User avatar (0002151)
ivan (administrator)
2009-11-19 21:18

Think this one was my fault, sorry. Off the top of my head I think the function got deprecated and I intended to clean this up later, but clearly forgot.
User avatar (0002230)
paulh (administrator)
2009-12-23 17:00

r5968 adds this patch to svn (3.x and trunk)
User avatar (0002312)
ivan (administrator)
2010-01-23 19:02

Fix released in v3.51 which is now available

- Issue History
Date Modified Username Field Change
2009-11-10 13:18 paulh New Issue
2009-11-14 14:23 paulh Note Added: 0002149
2009-11-14 14:23 paulh Assigned To => paulh
2009-11-14 14:23 paulh Status new => assigned
2009-11-14 14:23 paulh Fixed in Version => 3.50p1
2009-11-14 19:27 paulh Note Added: 0002150
2009-11-19 21:18 ivan Note Added: 0002151
2009-12-23 17:00 paulh Note Added: 0002230
2009-12-23 17:00 paulh Status assigned => resolved
2009-12-23 17:00 paulh Resolution open => fixed
2009-12-23 17:00 paulh Fixed in Version 3.50p1 => Current SVN
2009-12-23 17:00 paulh Target Version => 3.50p1
2010-01-23 19:01 ivan Fixed in Version Current SVN => 3.51
2010-01-23 19:02 ivan Note Added: 0002312
2010-01-23 19:02 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker