SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001022SiT!incidentspublic2009-12-24 15:222010-01-23 19:02
Reporterpaulh 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.50 
Target Version3.51Fixed in Version3.51 
Summary0001022: Drafts functionality doesn't work in cyrilic
DescriptionHello,

I've got a new incident. Clicked on Update, set SLA Target and Update text in Cyrillic
After clickicng Update Incident button update fails win an error: Multiple drafts exist please select one.
There is only one draft but the text is

    %u0413%u043E%u0442%u043E%u0432%u0438%u0442%u0441%u044F %u0437%u0430%u0434%u0430%u043D%u0438%u0435 %u0434%u043B%u044F %u043F%u0440%u043E%u0433%u0440%u0430%u043C%u043C%u0438%u0441%u0442%u0430


instead of

    ????? ???????? ????????????.


If I edit this draft and fix the text, update fails and if I leave the distorted text update succeeds
This error appears on all updates.
I've got clean install. The first incident was updated OK, but today I have 2 new tickets and update fails.

Reported in the forums http://sitracker.org/forum/viewtopic.php?f=4&t=1416948 [^] and reproduced
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0001051closedpaulh Drafts functionality doesn't work in cyrilic 

-  Notes
User avatar (0002242)
paulh (administrator)
2009-12-24 15:24

Seems Mantis cant handle Cyrillic either, review forum for exact text
User avatar (0002243)
paulh (administrator)
2009-12-24 15:33

This happens even if drafts is created as UTF8
User avatar (0002245)
paulh (administrator)
2009-12-24 15:51

This is caused by the javascript not properly handling UTF8 by the looks of things
User avatar (0002246)
paulh (administrator)
2009-12-26 14:44

r5973 for 3.x and trunk resolves this, UTF8 now supported
User avatar (0002308)
ivan (administrator)
2010-01-23 19:02

Fix released in v3.51 which is now available

- Issue History
Date Modified Username Field Change
2009-12-24 15:22 paulh New Issue
2009-12-24 15:23 paulh Status new => confirmed
2009-12-24 15:23 paulh Product Version => 3.50
2009-12-24 15:23 paulh Description Updated View Revisions
2009-12-24 15:24 paulh Note Added: 0002242
2009-12-24 15:33 paulh Note Added: 0002243
2009-12-24 15:51 paulh Note Added: 0002245
2009-12-26 12:29 paulh Status confirmed => assigned
2009-12-26 12:29 paulh Assigned To => paulh
2009-12-26 14:44 paulh Note Added: 0002246
2009-12-26 14:44 paulh Status assigned => resolved
2009-12-26 14:44 paulh Resolution open => fixed
2009-12-26 14:44 paulh Fixed in Version => Current SVN
2009-12-26 14:44 paulh Target Version => 3.50p1
2010-01-23 19:01 ivan Fixed in Version Current SVN => 3.51
2010-01-23 19:02 ivan Note Added: 0002308
2010-01-23 19:02 ivan Status resolved => closed
2010-01-25 10:44 ivan Relationship added has duplicate 0001051


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker