SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001051SiT!incidentspublic2010-01-25 09:302010-03-27 12:30
Reportersancho78rus 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.51 
Target Version3.60 LTSFixed in Version3.60 LTS 
Summary0001051: Drafts functionality doesn't work in cyrilic
DescriptionAgain 0001022: Drafts functionality doesn't work in cyrilic.
TagsNo tags attached.
Attached Filesjpg file icon 1.jpg [^] (88,112 bytes) 2010-02-12 09:54


jpg file icon 2.jpg [^] (54,349 bytes) 2010-02-12 09:54


diff file icon 1051.diff [^] (5,523 bytes) 2010-02-13 13:29 [Show Content]

- Relationships
duplicate of 0001022closedpaulh Drafts functionality doesn't work in cyrilic 
related to 0001069closed new bug after resolving [0001051] Drafts functionality doesn't work in cyrilic 

-  Notes
User avatar (0002327)
ivan (administrator)
2010-01-25 10:45

Thanks for the bug report, can you be more specific? Exactly what doesn't work and what happens instead of what you expect to happen?
(0002328)
sancho78rus (reporter)
2010-01-25 11:03

When update incident and write cirillic symbols - Failed - multiple drafts exist. When write in english - its ok.
(0002348)
sancho78rus (reporter)
2010-02-11 11:32

so what about this bug?
can you reproduce it?
(0002349)
sancho78rus (reporter)
2010-02-11 17:27

or may be you can tell me what to do to turn off drafts? bcause it seems to me that it is the final step for us to use SiT
User avatar (0002350)
paulh (administrator)
2010-02-11 20:15

Hi sancho78rus ,

I've just tried to reproduce this with 3.51 with the following test

6) é, à, è, ê, î, ç
7) Soluções
9) ??????? ????
A) AÄEIOÖUÜ Edelweiß
B) Español
C) ???????
D) ??????????
E) ??????????
F) # ?? / ???
G) ???
H) ??
I) æ, ø, å, Æ, Ø, Å
J) ?u?op ?p?sdn?
===[END]===


In both draft updates and emails and it saved the draft and retrieved the draft successfully. For updates I used this as the body and for emails I used these strings in both the body and the subject.

Can you attach a screenshot of what you are seeing as I'm struggling to reproduce this and if you could send a copy of the text your using just on the off chance its a 'odd' character.

As for turning drafts of this is unfortunately not possible.

Cheers
Paul
(0002353)
sancho78rus (reporter)
2010-02-12 09:56

screenshots:
1.jpg: when you type in everything in cirillic - 2.jpg appears. Every time. But in english - it ok.
User avatar (0002354)
ivan (administrator)
2010-02-12 12:14

Hi, paul and I are both confused as to where the bug lies here. It's difficult for us because neither of us speak Russian and can't understand the cirillic characters in your screenshot. However it seems that your two screenshots appear to be showing the drafts function operating normally, unless I'm mistaken the second screenshot shows the text you entered in (1) stored as a draft update.

The message "multiple drafts exist" is perhaps a little misleading because it's in English and what it really means is that "at least one draft has been previously saved". This string needs translating into Russian.
(0002355)
sancho78rus (reporter)
2010-02-12 12:26

"the second screenshot shows the text you entered in (1) stored as a draft update".
yes. its the same text.
may be we can turn off drafts by setting comments in some strings in code?
User avatar (0002356)
paulh (administrator)
2010-02-12 13:06

Hi,

You can use the draft by selecting the paper and pen icon, its not a trivial item to disable the draft feature the ideal situation is to get drafts working for you.

If you click the paper and pen it will allow you to use the draft

Cheers
Paul
(0002357)
sancho78rus (reporter)
2010-02-12 13:41

i cant do so - there is loop. everything repeates again when i press paper and draft opens.
(0002358)
sancho78rus (reporter)
2010-02-12 13:46

there is no way to write update in cirillic
User avatar (0002359)
ivan (administrator)
2010-02-12 13:59

So... if I'm understanding correctly you're saying that when you have a draft with text in cirillic it is not possible to edit that draft update?

When you click the "paper & pen" icon shown in screenshot 2 nothing happens?

Sorry that we're finding it difficult to understand the bug, but both Paul and Myself have tested this quite a lot and can't seem to make it break.
(0002360)
sancho78rus (reporter)
2010-02-12 14:02

something else...
1) when i try to update (fill in "Update" field) incident in cirillic even when draft dont save automaticaly (just quickly type some russian letters - and press "upsate incident" button before draft saves automaticaly) - there is an error (just "Failed. Wait while you'll be redirected" - without any words about drafts).
2) when i open draft (as you say - click on paper) and try to update incident again - Failed. But if I add some non-cirillic text in Update field (without deleting cirillic text) - everything ok.

may be it helps.
may be problem not with drafts.
(0002361)
sancho78rus (reporter)
2010-02-12 14:06

"When you click the "paper & pen" icon shown in screenshot 2 nothing happens?"
- after it i redirected to update incident page. and when i press Update incident button - the same error again.
(0002362)
sancho78rus (reporter)
2010-02-12 14:08
edited on: 2010-02-12 14:09

when i type update text in cirillic and press "update incident" button before draft saves automaticaly - there is error "The form field Update must not be left blank"

(0002363)
sancho78rus (reporter)
2010-02-12 20:48

it seems to me that i understand what the problem.
if the last letter in Update fileld non cirillic (english or digit) - drafts works and everything is ok. even if other letters cirillic.
but if last letter cirillic - error.
so error appears ONLY when LAST letter in update field cirillic.
User avatar (0002364)
paulh (administrator)
2010-02-13 12:14

Hi,

Can you ensure you have fully upgraded to 3.51 as I've tried again with the following text "??? ??????? ???? (ru-RU) ?????????? ?? ????? ?????? ??????" and don't get the problem.

One thing I do not from your screenshots is "Multiple drafts exist please select one" is in english where as in my 3.51 its in Russian (C????????? ????????? ??????????, ??????????, ???????? ????), looking back from the commits this string was added in SiT 3.50 so would appear your still running some 3.45 code which would possibly explain this problem as 3.51 is the first release where the drafts work when using unicode characters
(0002365)
sancho78rus (reporter)
2010-02-13 12:34

i'v just downloaded 3.51 again.
but http://sit.srv/incident_update.php [^] still shows error "Multiple drafts exist please select one".
(0002366)
sancho78rus (reporter)
2010-02-13 12:45

After some experiments i cannot repeat this error again (may be cash?).

But there is still error "The form field Update must not be left blank" if update text only cirillic. If there is at least one english symbol in update field
User avatar (0002367)
paulh (administrator)
2010-02-13 12:50

Hi,

OK I can reproduce this error now with "??? ??????? ???? ?????????? ?? ????? ?????? ??????" against 3.51 and latest SVN code so will do some investigation
(0002368)
sancho78rus (reporter)
2010-02-13 12:56

great!
will be waiting for patch very much...
User avatar (0002369)
paulh (administrator)
2010-02-13 13:01

The problem is caused by incident_update.php line 561 expectingbody text to contain at least one of the characters a-z or 0-9 and is case insensitive hence never catches Cyrillic chars (or any non english charatcer)
User avatar (0002370)
paulh (administrator)
2010-02-13 13:31

Hi,

Commit 6077 resolved this issue in trunk and 3.x, a patch has been uploaded to this bug report (1051.diff) which can be applied to the 3.51 release to resolve the issue

- Issue History
Date Modified Username Field Change
2010-01-25 09:30 sancho78rus New Issue
2010-01-25 10:44 ivan Relationship added duplicate of 0001022
2010-01-25 10:45 ivan Note Added: 0002327
2010-01-25 10:45 ivan Status new => feedback
2010-01-25 11:03 sancho78rus Note Added: 0002328
2010-02-11 11:32 sancho78rus Note Added: 0002348
2010-02-11 17:27 sancho78rus Note Added: 0002349
2010-02-11 20:15 paulh Note Added: 0002350
2010-02-12 09:54 sancho78rus File Added: 1.jpg
2010-02-12 09:54 sancho78rus File Added: 2.jpg
2010-02-12 09:56 sancho78rus Note Added: 0002353
2010-02-12 12:14 ivan Note Added: 0002354
2010-02-12 12:26 sancho78rus Note Added: 0002355
2010-02-12 13:06 paulh Note Added: 0002356
2010-02-12 13:41 sancho78rus Note Added: 0002357
2010-02-12 13:46 sancho78rus Note Added: 0002358
2010-02-12 13:59 ivan Note Added: 0002359
2010-02-12 14:02 sancho78rus Note Added: 0002360
2010-02-12 14:06 sancho78rus Note Added: 0002361
2010-02-12 14:08 sancho78rus Note Added: 0002362
2010-02-12 14:09 sancho78rus Note Edited: 0002362 View Revisions
2010-02-12 20:48 sancho78rus Note Added: 0002363
2010-02-13 12:14 paulh Note Added: 0002364
2010-02-13 12:34 sancho78rus Note Added: 0002365
2010-02-13 12:45 sancho78rus Note Added: 0002366
2010-02-13 12:50 paulh Note Added: 0002367
2010-02-13 12:50 paulh Status feedback => confirmed
2010-02-13 12:56 sancho78rus Note Added: 0002368
2010-02-13 12:59 paulh Status confirmed => assigned
2010-02-13 12:59 paulh Assigned To => paulh
2010-02-13 13:01 paulh Note Added: 0002369
2010-02-13 13:29 paulh File Added: 1051.diff
2010-02-13 13:31 paulh Note Added: 0002370
2010-02-13 13:31 paulh Status assigned => resolved
2010-02-13 13:31 paulh Resolution open => fixed
2010-02-13 13:31 paulh Fixed in Version => Current SVN
2010-02-13 13:31 paulh Target Version => 3.60
2010-02-13 17:29 ivan Relationship added related to 0001069
2010-03-27 11:16 ivan Fixed in Version Current SVN => 3.60 LTS
2010-03-27 12:30 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker