SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001098SiT!inbound emailpublic2010-02-23 08:492013-01-19 18:50
Reporternicdev 
Assigned Topaulh 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformWindowsOSWindows ServerOS Version2000+Later
Product Version3.51 
Target Version3.68Fixed in VersionCurrent SVN 
Summary0001098: Emails with .msg attachments import the messages as .jpeg
DescriptionWhen the inbound script imports an email with one or more .msg attachments (attached emails), the attachments are visible in the tracker as part1.jpeg ... part2.jpeg .. etc.

In this case the browser tries to open the attachments as jpeg files, but fails, and the only way to open these files is to save them on your desktop, rename them to .msg files and then to open them.
Tagsmajorimpact
Attached Files

- Relationships

-  Notes
User avatar (0002480)
paulh (administrator)
2010-02-25 20:44

Hi Nico,

I've tried to reproduce this with the latest code and been unable to reproduce, my .msg makes it into sit as a .msg and is handled correctly.

Could you enable debug logging and retrieve a message and I'll take a look.
 
Paul
User avatar (0002493)
ivan (administrator)
2010-02-25 21:16

I'm in a picky mood today, I apologise for this, but this bug isn't Major according to our scale at http://sitracker.org/wiki/Bugs#A_guide_to_bug_severity [^]
User avatar (0002549)
nicdev (developer)
2010-03-01 08:34

Hi Ivan,
I am not in a picky mood at all. I re-read the definition and i am sorry but for us it is "An important feature that is severely limited" as we receive a lot of emails as attachments.

Paul,
I will try again today with the latest stable 3.51 and and then with SVN to se if it is still the case.
i will post my findings here later;
Thanks
User avatar (0002554)
ivan (administrator)
2010-03-01 09:47

Nico,

Ah, that last comment from you might change things slightly. A .msg attachment is a MIME embedded email is it? That's a windows convention I'm not familiar with probably. If that's the case then you could be right and it is more important than I thought.

I'll need to see one of the emails that's failing, that'll help know whats going on. Thanks, and sorry for being picky, it's something that happens to me every so often ;)
User avatar (0002557)
nicdev (developer)
2010-03-01 10:16

Hi Ivan and Paul,

I have tested with 3.51 and it seems somewhere between 3.50 and 3.51 it was fixed. I confirm it works in 3.51.

Does anyone have an idea which revision as i would love to backport the changes to our Live 3.50 if possible.

In any event it can be closed now

Thanks
User avatar (0002559)
paulh (administrator)
2010-03-01 10:42

Hi Nico,

Not sure of which revision though 3.51 was just a bug fix release so you can either deploy the whole upgrade of if you run kdiff3 you can see the changes between the two and may be able to identify which file fixed this.
User avatar (0002572)
nicdev (developer)
2010-03-02 09:43

Paul,

I am not sure where either but it seems to be before 3.50, as my live 3.50 now works. The mails i was looking at, it seems, where imported before the upgrade to 3.50.

in any event this bug is squashed now ;)and can be closed.
User avatar (0002573)
ivan (administrator)
2010-03-02 10:00

Fixed sometime prior to 3.50. Thanks Nico.
User avatar (0003373)
nicdev (developer)
2010-08-23 11:14

Tested this morning, this is still an issue in 3.60 and 3.62. I am not sure where or why
User avatar (0003374)
nicdev (developer)
2010-08-23 13:16

Some info after dumping lots of debug like '$rawemail' and '$decoded', it seems that for parts (of a multipart email) with type 'message/rfc822' the script 'mime_parser.inc.php' does not return ['FileName'] or ['ContentDisposition'] value and not even a ['SubType']. (***See line 2185 in mime_parser.inc.php)

When we return to Inboundemail it gives it "partX.jpeg" as a filename because it cannot see a ['FileName']. (***See line 332 of inboundemail.php).

Any help appreciated
User avatar (0003375)
nicdev (developer)
2010-08-23 13:16

Thanks Ivan
User avatar (0003377)
Tomse (developer)
2010-08-26 14:18

Nicdev and I did some testings today on the current SVN (pre-3.63) we found out that the issue appears with the Outlook client connected to an Exchange server.

We haven't tested with Outlook Express but I suspect the same problem.

Sending a mail with attachment from the Exchange servers webinterface the attachement is registered as a correct file.

doing a "file" on the outlook sent mail attachement results in this answer : ASCII mail text, with CRLF line terminators

doing the same from a correct registered mail-attachement from gmail : Hangul (Korean) Word Processor File 2000

and from thunderbird : smtp mail text
User avatar (0004129)
dipohl (developer)
2011-08-02 08:57

Have the same problem with TXT-Attachments here with Groupwise Mailserver and SiT! v3.63 p1.

Fyi & cheers, Gabriele
User avatar (0004311)
dipohl (developer)
2011-09-27 10:04

Problem is still existent with SiT! v3.65 and very annoying :-(
It's reducing user acceptance of SiT! which is a pity..
User avatar (0004312)
nicdev (developer)
2011-09-27 12:40

On the same server WAMP:
One instance of SiT! v3.65LTS - .msg file imports as "part1.jpeg"
One instance (production) of SiT! v3.62 - .msg files import correctly

Used the same email in both cases
both emails sent from MS Outlook through an exchange server
both imported using IMAP
User avatar (0004460)
Tomse (developer)
2012-03-04 10:36

since I don't have my testing setup anymore.

can you attach some dummy files that causes the problems ?
User avatar (0004513)
ivan (administrator)
2012-08-28 13:42

We need more information (examples and steps to repro) added to this bug report before we can fix this. I have looked several times since it was reported as still existing back in August 2010 but I've never managed to get to the bottom of it.
User avatar (0004649)
paulh (administrator)
2013-01-18 17:56

we've seen this on our production system today so have sample messages, seems to be when an email is sent as an attachment and MS word is used as the editor in Outlook, will fix this one on the 3.x branch
User avatar (0004650)
paulh (administrator)
2013-01-19 18:50

r7557 and e6cf045 save attached emails as the subject.eml which is more in keeping with desktop email clients, looking back though the logs the jpeg issue was resolved in 3.66 but this improved usability further as the previous fx just imported them as partX

- Issue History
Date Modified Username Field Change
2010-02-23 08:49 nicdev New Issue
2010-02-25 20:44 paulh Note Added: 0002480
2010-02-25 20:44 paulh Status new => feedback
2010-02-25 21:16 ivan Note Added: 0002493
2010-02-25 21:16 ivan Severity major => minor
2010-03-01 08:34 nicdev Note Added: 0002549
2010-03-01 09:47 ivan Note Added: 0002554
2010-03-01 09:51 ivan Severity minor => major
2010-03-01 10:16 nicdev Note Added: 0002557
2010-03-01 10:42 paulh Note Added: 0002559
2010-03-02 09:43 nicdev Note Added: 0002572
2010-03-02 10:00 ivan Note Added: 0002573
2010-03-02 10:00 ivan Status feedback => closed
2010-03-02 10:00 ivan Resolution open => fixed
2010-08-23 11:14 nicdev Assigned To => nicdev
2010-08-23 11:14 nicdev Note Added: 0003373
2010-08-23 11:14 nicdev Status closed => feedback
2010-08-23 11:14 nicdev Resolution fixed => reopened
2010-08-23 13:16 nicdev Note Added: 0003374
2010-08-23 13:16 nicdev Status feedback => assigned
2010-08-23 13:16 nicdev Note Added: 0003375
2010-08-23 13:16 nicdev Assigned To nicdev => ivan
2010-08-23 13:16 nicdev Status assigned => feedback
2010-08-26 14:18 Tomse Note Added: 0003377
2010-08-26 14:18 Tomse Status feedback => confirmed
2010-08-28 14:30 paulh Status confirmed => assigned
2011-08-02 08:57 dipohl Note Added: 0004129
2011-09-27 10:04 dipohl Note Added: 0004311
2011-09-27 10:32 ivan Tag Attached: majorimpact
2011-09-27 12:38 nicdev Summary Emails with .msg attachments import the messages as .jpg => Emails with .msg attachments import the messages as .jpeg
2011-09-27 12:40 nicdev Note Added: 0004312
2011-10-07 11:05 ivan Target Version => 3.66 LTS
2012-03-04 10:36 Tomse Note Added: 0004460
2012-04-20 13:55 Tomse Target Version 3.66 LTS => 3.67 LTS
2012-08-04 14:30 ivan Target Version 3.67 LTS =>
2012-08-28 13:42 ivan Note Added: 0004513
2013-01-18 17:56 paulh Note Added: 0004649
2013-01-18 17:56 paulh Assigned To ivan => paulh
2013-01-18 17:56 paulh Target Version => 3.68
2013-01-19 18:50 paulh Note Added: 0004650
2013-01-19 18:50 paulh Status assigned => resolved
2013-01-19 18:50 paulh Resolution reopened => fixed
2013-01-19 18:50 paulh Fixed in Version => Current SVN


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker