SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001133VMInstallationpublic2010-03-11 16:022011-02-22 15:14
ReporterTomse 
Assigned ToTomse 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version 
Target VersionFixed in Version3.60 
Summary0001133: Create a production ready VM
DescriptionA new VM should be created which specs are good enough for running in production.

This triggers some things needing to be done:
Editing the VM page in the wiki, how to change passwords on the Linux user and MySQL user.

Scripts to make the VM production ready (remove executable from sitreset, situpdate etc).

Specs should be:
HDD >= 40GB
Mem >= 512MB

Script to handle network when starting up the first time, or from a script.

backup/restore scripts should be improved.

Feel free to add more things
--------------------------------------------------------------------------------
Current VM in development:
15GB system
60GB webroot (SiT)
512MB Ram

Needed :
Splash screen with SiT Logo
script/guide to change l10n settings

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002648)
paulh (administrator)
2010-03-11 17:49

Hi,

Not really sure about this as an idea. Don't think I'd trust running a production system on a machine I'd just downloaded.

Could people just add an additional disk to the existing machine and increase the memory if they wanted to run it in production (we might need to provide instructions).

Also what happens about updates etc it effectively moves the burden of patching etc onto us.

As an asside our install currently have 40G of attachments + the database + the app itself so 40G may be abit limiting? All depends on whos using it
User avatar (0002652)
Tomse (manager)
2010-03-11 21:02

I agree with your thoughts, I took the >=40GB because ericthefish mentioned you have aprox 1 gb of database, and 20gigs of attachments.

it is no problem choosing a larger disksize, it is not going to be allocated until data will be stored on it, thus decreasing performance alittle.

memory size is easy to adjust, just as easy as inputting a number in a text box.

regarding the documentation there is going to be some, but if we give an as-is disclaimer that we are not going to support the OS, just supplying a ready-to-run sit installation, we should be able to give it a try.

this could benefit in people will run the VM rather than xampp for windows ;-)

of course there will be some setup scripts to help the user to set passwords, and what I mentioned in the original post.

I've been wondering for a long time if we should do this, but stopped myself. now today ericthefish questioned about why the vm couldn't run in production, and otherwise for the low amount mem and disk, the ability to crash the server (resetting, upgrading to svn etc), and the weak passwords, it's quite possible to have it as a production server.

the low amount we have in the VM today is to make sure that the test vm can run on most computers.

good thing we have this debate.. now I wonder If it should continue in the forum instead ?
User avatar (0002661)
paulh (administrator)
2010-03-13 13:28

I don't think this should be a separate VM from our existing demo one.

How would we cope with people upgrading their version of SiT on such a machine, as if they don't have Linux skills then could be stuck.

I'm in favor of us distributing an appliance version of SiT though we need to get the upgrade mechanism sort, ideally this would be done 'online' though where someway of this at the moment.

Not sure whether this should be tagged for 3.6 either
User avatar (0002705)
ivan (administrator)
2010-03-15 11:34

Maybe we should use a BSD for this rather than Ubuntu. Just an idea.
User avatar (0002706)
paulh (administrator)
2010-03-15 11:59

Personally I think we should stick to Linux as more people know that (and its more common place in the appliance/test VM market) so would have a higher takeup/acceptance rate. if people what to run SiT on more eclectic platforms they will probably have the skills to do this thereselves
User avatar (0002722)
Tomse (manager)
2010-03-17 18:09
edited on: 2010-03-17 18:18

Windows only People are quite affraid of just listening to the word Linux, so I guess the target will not be Windows Admins.

People who have a small knowledge regarding Linux might want to try it out.
It's a very small matter to add another harddrive, mount it and have the web folder there.

if people expect large amounts of data, they wouldn't want to run on a VM anyway, and they would most likely prepare the installations themselves.

the VM for 3.60 is ready to go into production (just need SiT3.60), I've changed some of the specs. HDD is now 60GB, Mem is 512MB.
Adding a new disk is easy, adding more mem, even easier.

I've added tools to make the VM production ready.

The same matter in where a server's free hard drive space gets close to be 0 the doesn't matter if it is a VM or a box. issues are the same.

I wouldn't be afraid of putting the VM into production myself.

you are more than welcome to have a go with the new 3.51 version that is ready, let me know and I'll upload it to you (or just download the scripts from the SVN to the existing version)

User avatar (0002725)
ivan (administrator)
2010-03-17 20:16

No point this sitting unconfirmed any more since it's largely done anyway :-)
(0002762)
sancho78rus (reporter)
2010-03-20 18:41

What VM would you use?
Is it VMWare?
User avatar (0002779)
Tomse (manager)
2010-03-20 23:36
edited on: 2010-03-20 23:38

yes it's VMware :-)

you can read alittle about our current VM here

http://sitracker.org/wiki/Vm [^]

User avatar (0002784)
Tomse (manager)
2010-03-21 12:21

VM created, and documented so it can be reproduced
User avatar (0002785)
Tomse (manager)
2010-03-21 12:22

reopened. to be ready for 3.60
User avatar (0002887)
Tomse (manager)
2010-03-28 11:52

VM is production ready after running script "sitproduction", specs for VM set higher

- Issue History
Date Modified Username Field Change
2010-03-11 16:02 Tomse New Issue
2010-03-11 16:04 Tomse Category other => VM
2010-03-11 17:49 paulh Note Added: 0002648
2010-03-11 21:02 Tomse Note Added: 0002652
2010-03-13 13:28 paulh Note Added: 0002661
2010-03-15 11:34 ivan Note Added: 0002705
2010-03-15 11:59 paulh Note Added: 0002706
2010-03-17 18:09 Tomse Note Added: 0002722
2010-03-17 18:18 Tomse Note Edited: 0002722 View Revisions
2010-03-17 20:15 ivan Status new => assigned
2010-03-17 20:15 ivan Assigned To => Tomse
2010-03-17 20:16 ivan Note Added: 0002725
2010-03-20 09:48 Tomse Description Updated View Revisions
2010-03-20 15:05 Tomse Description Updated View Revisions
2010-03-20 16:57 ivan Severity minor => feature
2010-03-20 18:41 sancho78rus Note Added: 0002762
2010-03-20 23:36 Tomse Note Added: 0002779
2010-03-20 23:38 Tomse Note Edited: 0002779 View Revisions
2010-03-21 12:21 Tomse Note Added: 0002784
2010-03-21 12:21 Tomse Status assigned => resolved
2010-03-21 12:21 Tomse Fixed in Version => Current SVN
2010-03-21 12:21 Tomse Resolution open => fixed
2010-03-21 12:22 Tomse Note Added: 0002785
2010-03-21 12:22 Tomse Status resolved => feedback
2010-03-21 12:22 Tomse Resolution fixed => reopened
2010-03-24 13:33 ivan Project SiT! => VM
2010-03-24 13:33 ivan Category VM => (No Category)
2010-03-24 16:28 Tomse Category (No Category) => Installation
2010-03-24 16:28 Tomse Product Version 3.60 LTS =>
2010-03-24 16:28 Tomse Fixed in Version Current SVN =>
2010-03-24 16:28 Tomse Target Version 3.60 LTS =>
2010-03-28 11:52 Tomse Note Added: 0002887
2010-03-28 11:52 Tomse Status feedback => assigned
2010-03-28 11:52 Tomse Status assigned => resolved
2010-03-28 11:52 Tomse Fixed in Version => 3.60
2010-03-28 11:52 Tomse Resolution reopened => fixed
2011-02-22 15:14 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker