SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001182SiT!feedbackpublic2010-03-23 10:592010-03-27 12:30
Reporternicdev 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.51 
Target Version3.60 LTSFixed in Version3.60 LTS 
Summary0001182: Contact can access the feedback form multiple times
DescriptionOnce completed, a contact can click on the link he received again and the feedback form can be submitted infinitely.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002838)
ivan (administrator)
2010-03-23 14:14

Haven't had chance to confirm this yet, but if it confirmes OK then it needs fixing for 3.60 if we can.
User avatar (0002841)
nicdev (developer)
2010-03-23 14:37

Ivan,

As we discussed in line 386 of feedback.php we need to change the code to:

if (!$_REQUEST['rr'])
{
   $rsql .= "AND completed='no' ";
}

because the contact always arrives from the link with $_REQUEST['rr'] not set, and thus will always see the form. Also we need to change the 'yes' to 'no', to only show the form when it has not been completed.
User avatar (0002854)
paulh (administrator)
2010-03-24 20:18

can repro
User avatar (0002857)
paulh (administrator)
2010-03-24 21:23

r6336 and bcde971 resolve this

- Issue History
Date Modified Username Field Change
2010-03-23 10:59 nicdev New Issue
2010-03-23 14:14 ivan Note Added: 0002838
2010-03-23 14:14 ivan Target Version => 3.60 LTS
2010-03-23 14:37 nicdev Note Added: 0002841
2010-03-24 20:18 paulh Note Added: 0002854
2010-03-24 20:18 paulh Status new => confirmed
2010-03-24 21:18 paulh Status confirmed => assigned
2010-03-24 21:18 paulh Assigned To => paulh
2010-03-24 21:23 paulh Note Added: 0002857
2010-03-24 21:23 paulh Resolution open => fixed
2010-03-24 21:23 paulh Fixed in Version => Current SVN
2010-03-24 21:25 paulh Status assigned => resolved
2010-03-27 11:16 ivan Fixed in Version Current SVN => 3.60 LTS
2010-03-27 12:30 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker