SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001204SiT!SLAspublic2010-03-28 13:382010-05-29 14:20
Reporterpaulh 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.61 LTSFixed in Version3.61 LTS 
Summary0001204: Incident SLA calculations wrong
DescriptionIncident SLAs calculations are wrong

Have an SLA which has a critical priority with an IR or 30minutes

Log a call as critical against this and instantly is shows as being out of SLA

Open for 3 minutes Active
Initial Response 30 minutes late

This happened on our live system yesterday as well (prior to DST) have reproduced this with my install of SiT as well
TagsNo tags attached.
Attached Filespng file icon incident.png [^] (94,809 bytes) 2010-03-28 13:38


png file icon service.png [^] (66,107 bytes) 2010-03-28 13:39


? file icon db.sql [^] (4,032 bytes) 2010-05-06 19:57
png file icon error.png [^] (78,449 bytes) 2010-05-06 19:58

- Relationships

-  Notes
User avatar (0002890)
paulh (administrator)
2010-03-28 13:39

Ignore the warning in the above screenshot I've logged that as 1203
User avatar (0002892)
kieran (administrator)
2010-03-28 15:15

I can sorta confirm; I get a slightly different problem:

Open for 2 minutes - Active
Initial Response due now
Review Due 0 minutes ago!
User avatar (0002893)
ivan (administrator)
2010-03-28 15:27

Paul, does this happen in version prior to 3.60 do you know?
User avatar (0002894)
ivan (administrator)
2010-03-28 15:52

Seems to happen even without the DST adjustment, and the incident_get_next_target() function hasn't changed for months. Confused.
User avatar (0002895)
paulh (administrator)
2010-03-28 16:20

Ivan, it happens on our live 3.45 (ish) install which is where I spotted it last night (44755). Admit ably I did log the call with our 3.6 install. I find it hard to believe no one had spotted this before
User avatar (0003150)
paulh (administrator)
2010-05-06 19:46

Been having a look and it appear to be the calculate_working_time function which is returning 60 rather than 6

Can't repro this with new incidents though can with the open I first spotted this with, suspect its something about the time it was opened, will upload a DB export onces sanatised
User avatar (0003151)
paulh (administrator)
2010-05-06 19:59

error.png shows the current status and db.sql is the relevant incident and update rows

For some reason it things that between 8:51pm and 8:44pm theres 60 mins
User avatar (0003185)
ivan (administrator)
2010-05-29 11:25

Fixed in svn r6490
There is a special case for working time calculations where both the start and the end time are outside of the working week, if this is the case we now return 0 minutes, because no time at all was working time.
User avatar (0003213)
ivan (administrator)
2010-05-29 14:20

Released in v3.61

- Issue History
Date Modified Username Field Change
2010-03-28 13:38 paulh New Issue
2010-03-28 13:38 paulh File Added: incident.png
2010-03-28 13:39 paulh File Added: service.png
2010-03-28 13:39 paulh Note Added: 0002890
2010-03-28 15:15 kieran Note Added: 0002892
2010-03-28 15:15 kieran Status new => confirmed
2010-03-28 15:15 kieran Product Version => 3.60 LTS
2010-03-28 15:15 kieran Target Version => 3.61 LTS
2010-03-28 15:27 ivan Note Added: 0002893
2010-03-28 15:52 ivan Note Added: 0002894
2010-03-28 16:20 paulh Note Added: 0002895
2010-03-28 17:33 ivan Product Version 3.60 LTS => 3.45
2010-05-06 19:46 paulh Note Added: 0003150
2010-05-06 19:57 paulh File Added: db.sql
2010-05-06 19:58 paulh File Added: error.png
2010-05-06 19:59 paulh Note Added: 0003151
2010-05-29 10:24 ivan Status confirmed => assigned
2010-05-29 10:24 ivan Assigned To => ivan
2010-05-29 11:25 ivan Note Added: 0003185
2010-05-29 11:25 ivan Status assigned => resolved
2010-05-29 11:25 ivan Fixed in Version => Current SVN
2010-05-29 11:25 ivan Resolution open => fixed
2010-05-29 13:39 ivan Fixed in Version Current SVN => 3.61 LTS
2010-05-29 14:20 ivan Note Added: 0003213
2010-05-29 14:20 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker