SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001239SiT!Skillspublic2010-04-06 21:142010-05-29 14:20
Reportersancho78rus 
Assigned Topaulh 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.60 LTS 
Target Version3.61 LTSFixed in Version3.61 LTS 
Summary0001239: Bugs managing skills
DescriptionSkills does not savese corrctly:
1) open http://demo.sitracker.org/edit_user_skills.php [^]
2) move all skills to HAVE Skills (>>)
3) without saving try to remove only one skill to NO Skills
4) save

nothing saves
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002959)
paulh (administrator)
2010-04-06 21:33

Hi,

Just before you click < do you have all the items in the right list selected? If so this is working as designed as its intended that you can select and move multiple, whether they should be selected by default I'm not 100% sure
(0002962)
sancho78rus (reporter)
2010-04-06 21:40

No i have only one item selected in the right. You can easily reproduce it in your demo.
User avatar (0002964)
paulh (administrator)
2010-04-06 21:44

Hi Sancho, it was on our demo I was trying, I've just used firefox and IE and have been unable to reproduce this problem by pressing the < button to remove one item

Does this only happen in certain browsers?
(0002966)
sancho78rus (reporter)
2010-04-06 21:52

I'v just tryed in IE8 - the same bug.
I tryed with user Manager.
Go to Edit my skills (Manager have only Windows server 2003 skill now)
Try to press >>
Then select Windows server 2008 and press <
Then save.
You can see that user still have onli Windows server 2003 skill
User avatar (0002968)
paulh (administrator)
2010-04-07 08:38

Yeap can reproduce this one this morning in both IE8 and Firefox, not sure what I was doing differently last night (apart from using engineer) and I couldn't reproduce this one to safe my life.

The interesting thing is the list has "Windows 2003", blank entry, then the rest, wondering if its tripping up over that blank entry?
User avatar (0002970)
paulh (administrator)
2010-04-07 19:51
edited on: 2010-04-07 20:00

This is caused by a <select> being used for the skills list and the update using $_POST which is empty and nothing is selected in the expertise list

EDIT: would appear webtrack.js:populateHidden is supposed to populate a hidden variable with these

User avatar (0002971)
paulh (administrator)
2010-04-07 20:21

r6419 and 53a14fc resolve this
User avatar (0003203)
ivan (administrator)
2010-05-29 14:20

Released in v3.61

- Issue History
Date Modified Username Field Change
2010-04-06 21:14 sancho78rus New Issue
2010-04-06 21:33 paulh Note Added: 0002959
2010-04-06 21:33 paulh Status new => feedback
2010-04-06 21:40 sancho78rus Note Added: 0002962
2010-04-06 21:40 sancho78rus Status feedback => new
2010-04-06 21:44 paulh Note Added: 0002964
2010-04-06 21:52 sancho78rus Note Added: 0002966
2010-04-07 08:38 paulh Note Added: 0002968
2010-04-07 08:38 paulh Assigned To => paulh
2010-04-07 08:38 paulh Severity minor => major
2010-04-07 08:38 paulh Status new => assigned
2010-04-07 08:38 paulh Target Version => 3.61 LTS
2010-04-07 19:51 paulh Note Added: 0002970
2010-04-07 20:00 paulh Note Edited: 0002970 View Revisions
2010-04-07 20:21 paulh Note Added: 0002971
2010-04-07 20:21 paulh Status assigned => resolved
2010-04-07 20:21 paulh Resolution open => fixed
2010-04-07 20:21 paulh Fixed in Version => Current SVN
2010-05-29 13:39 ivan Fixed in Version Current SVN => 3.61 LTS
2010-05-29 14:20 ivan Note Added: 0003203
2010-05-29 14:20 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker