SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001241SiT!incidentspublic2010-04-06 21:202010-05-29 14:20
Reportersancho78rus 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.60 LTS 
Target Version3.61 LTSFixed in Version3.61 LTS 
Summary0001241: Bad long texts on charts
DescriptionWhen chart lables not short - there are bad simbols in the end and lables are cut off. See attache.
TagsNo tags attached.
Attached Filespng file icon sit_chart_2010-04-07.png [^] (11,045 bytes) 2010-04-06 21:20


png file icon ibs.png [^] (35,390 bytes) 2010-04-21 20:12


png file icon ibs2.png [^] (35,857 bytes) 2010-04-21 21:17

- Relationships

-  Notes
(0002958)
sancho78rus (reporter)
2010-04-06 21:21

It happens with installed fonts plugin
User avatar (0002960)
paulh (administrator)
2010-04-06 21:35

Hi,

Could you possibly email me the strings your using to paul [at] sitracker.org (as Mantis will mangle them) and I'll take a look here,
(0002965)
sancho78rus (reporter)
2010-04-06 21:46

I've sent you mail
User avatar (0003087)
paulh (administrator)
2010-04-19 20:12

Hi,

Thanks for the text, I've added these to my install though couldn't reproduce this, looking at the code it looks like we've already fixed this for 3.61 as we now use mb_substr rather than substr as we did for 3.6 can you confirm?
(0003093)
sancho78rus (reporter)
2010-04-20 06:31

i dont have 3.61 now )
User avatar (0003098)
paulh (administrator)
2010-04-21 20:13

The display I get is ibs.png with 3.61 which looks to me correct (though I don't speak russian) can you confirm?
(0003099)
sancho78rus (reporter)
2010-04-21 20:28

It is better now but not excelent.
There should be "\" insted of "\\"
Also strings now longer but still they cut off (they should be some symbols longer)
User avatar (0003100)
paulh (administrator)
2010-04-21 21:18

I've fixed the \ (see ibs2.png) I've also added ellipsis when the string is shorted, with the current chart we're not able to show any more characters unfortunately. If this looks OK I'll commit this
(0003101)
sancho78rus (reporter)
2010-04-22 06:09

Yes thats it!
User avatar (0003102)
paulh (administrator)
2010-04-22 18:55

r6450 and 9675ed9 resolve this
User avatar (0003202)
ivan (administrator)
2010-05-29 14:20

Released in v3.61

- Issue History
Date Modified Username Field Change
2010-04-06 21:20 sancho78rus New Issue
2010-04-06 21:20 sancho78rus File Added: sit_chart_2010-04-07.png
2010-04-06 21:21 sancho78rus Note Added: 0002958
2010-04-06 21:35 paulh Note Added: 0002960
2010-04-06 21:35 paulh Status new => feedback
2010-04-06 21:46 sancho78rus Note Added: 0002965
2010-04-06 21:46 sancho78rus Status feedback => new
2010-04-19 20:12 paulh Note Added: 0003087
2010-04-19 20:12 paulh Status new => feedback
2010-04-20 06:31 sancho78rus Note Added: 0003093
2010-04-20 06:31 sancho78rus Status feedback => new
2010-04-21 20:12 paulh File Added: ibs.png
2010-04-21 20:13 paulh Note Added: 0003098
2010-04-21 20:28 sancho78rus Note Added: 0003099
2010-04-21 21:17 paulh File Added: ibs2.png
2010-04-21 21:18 paulh Note Added: 0003100
2010-04-22 06:09 sancho78rus Note Added: 0003101
2010-04-22 09:04 paulh Assigned To => paulh
2010-04-22 09:04 paulh Status new => assigned
2010-04-22 09:04 paulh Target Version => 3.61 LTS
2010-04-22 18:55 paulh Note Added: 0003102
2010-04-22 18:55 paulh Status assigned => resolved
2010-04-22 18:55 paulh Resolution open => fixed
2010-04-22 18:55 paulh Fixed in Version => Current SVN
2010-05-29 13:39 ivan Fixed in Version Current SVN => 3.61 LTS
2010-05-29 14:20 ivan Note Added: 0003202
2010-05-29 14:20 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker