SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001291SiT!triggerspublic2010-04-21 11:192011-02-14 13:18
Reporterivan 
Assigned Tokieran 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.90beta1Fixed in VersionCurrent GIT 
Summary0001291: TRIGGER_INCIDENT_CLOSED and default NOTICE_INCIDENT_CLOSED
DescriptionBy default a notice is generated when incidents are closed, the notice is sent to 'yourself' ie. {userid} == {$userid} which seems a tad pointless. If I closed it, I don't need a notification to tell me I closed it.

Additional InformationIt could be that a previous version of SiT had different default rules because we have quite a few users with the rule

{userid} != {$userid}

Which is also pretty useless as this one notifies if any incident is closed by anybody except myself, a bit of a bombardment of irrelevant info.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001290confirmed Default user triggers aren't configurable 

-  Notes
User avatar (0003586)
kieran (administrator)
2011-02-12 18:03

This rule appears not to be in the code, I think it was an old one from the initial triggers release, the current rule is more sensible.
User avatar (0003587)
kieran (administrator)
2011-02-12 18:04

There it is in the setup schema. We need to resolve how to set default triggers really.
User avatar (0003588)
kieran (administrator)
2011-02-12 18:07

Fixed in e587f0d - a proper solution will be in place for 3.90 though.

- Issue History
Date Modified Username Field Change
2010-04-21 11:19 ivan New Issue
2010-04-21 11:55 kieran Assigned To => kieran
2010-04-21 11:55 kieran Status new => assigned
2010-04-21 11:56 kieran Target Version => 4.0
2011-02-12 18:03 kieran Note Added: 0003586
2011-02-12 18:03 kieran Status assigned => closed
2011-02-12 18:03 kieran Resolution open => unable to reproduce
2011-02-12 18:04 kieran Note Added: 0003587
2011-02-12 18:04 kieran Status closed => assigned
2011-02-12 18:04 kieran Relationship added related to 0001290
2011-02-12 18:07 kieran Note Added: 0003588
2011-02-12 18:07 kieran Status assigned => resolved
2011-02-12 18:07 kieran Fixed in Version => Current GIT
2011-02-12 18:07 kieran Resolution unable to reproduce => fixed
2011-02-14 13:18 ivan Fixed in Version Current GIT => 3.90beta1
2011-02-14 13:18 ivan Fixed in Version 3.90beta1 => Current GIT
2011-02-14 13:18 ivan Target Version 4.0 => 3.90beta1


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker