SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001302SiT!triggerspublic2010-04-27 12:402010-07-21 21:29
Reportervitorcosta 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.60 LTS 
Target Version3.62 LTSFixed in Version3.62 LTS 
Summary0001302: Trigger action editor not work ok
Descriptionwhen in

triggers.php?mode=add&id=TRIGGER_INCIDENT_ASSIGNED&user=2

selecting notice two problems in editor bellow:

1) If expression have {currentuserid} the result saved in data base is replaced by 2 number ({currentuserid} == 2 will be 2 == 2)

2) If try a expression with two or more digites a space is placed between ( {userid} == 12 will be {userid} = 1 2)
Steps To Reproduce- Go to user profile
- Trigger
- Add Action
- Select NOTE
- Click in {currentuserid}
- Click in ==
- Click in 4
- Save
- The result will be 2 == 4 (Wrong) - {currentuserid} == 4 (Right)



- Go to user profile
- Trigger
- Add Action
- Select NOTE
- Click in {userid}
- Click in ==
- Click in 1
- CLick in 2
- Save
- The result will be {userid} == 1 2 (Wrong) - {userid} == 12 (Right)

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0003120)
paulh (administrator)
2010-04-29 20:09

Can confirm second point as we automatically add a space after each component

As for the first looking at the code this appears to be by design though I'll wait for Kieran/Ivan to confirm though I agree its confusing/not what you'd expect
User avatar (0003121)
kieran (administrator)
2010-04-29 20:26

Ivan wrote the GUI but I can't think of a reason we need to, only the connectors need spaces around them.
User avatar (0003181)
ivan (administrator)
2010-05-27 15:53

I agree we don't need the spaces. I'll try and get this fixed ASAP, but I've changed this to 'Major' since it's not 'Block' according to:

http://sitracker.org/wiki/Bugs#A_guide_to_bug_severity [^]
User avatar (0003249)
ivan (administrator)
2010-06-12 13:27

Fixed in svn r6506
Fixed in git 6881009
User avatar (0003333)
ivan (administrator)
2010-07-18 15:05

Released in v3.62

- Issue History
Date Modified Username Field Change
2010-04-27 12:40 vitorcosta New Issue
2010-04-29 20:09 paulh Note Added: 0003120
2010-04-29 20:09 paulh Status new => confirmed
2010-04-29 20:26 kieran Note Added: 0003121
2010-05-27 15:53 ivan Note Added: 0003181
2010-05-27 15:53 ivan Severity block => major
2010-06-03 10:31 ivan Assigned To => ivan
2010-06-03 10:31 ivan Status confirmed => assigned
2010-06-03 10:31 ivan Target Version => 3.62 LTS
2010-06-12 13:27 ivan Note Added: 0003249
2010-06-12 13:27 ivan Status assigned => resolved
2010-06-12 13:27 ivan Fixed in Version => Current SVN
2010-06-12 13:27 ivan Resolution open => fixed
2010-07-18 15:05 ivan Note Added: 0003333
2010-07-18 15:05 ivan Status resolved => closed
2010-07-21 21:29 ivan Fixed in Version Current SVN => 3.62 LTS


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker