SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001367SiT!incidentspublic2010-07-17 05:102010-07-21 21:29
Reportereckes 
Assigned ToTomse 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.61 LTS 
Target Version3.62 LTSFixed in Version3.62 LTS 
Summary0001367: Help Link on incidents detail screen broken
DescriptionThe incident_details screen has an header with a "?" help link. This is a JavaScript method where the parameter is the permission number of the screen. However auth.inc.php changes $permission into an array, and this results in a broken serialisation in html.
Steps To ReproduceOpen a detail popup for an incident and try to click the help link.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0003304)
ivan (administrator)
2010-07-17 09:33

Thanks again. I can confirm this. A long time ago we had a help page for each page based on the permission numbers. But the help text itself was very rubbish and eventually became out of date so we replaced it with a single page, looks like this bit of code got missed.
User avatar (0003308)
Tomse (developer)
2010-07-17 12:02

fixed in git dcf2545
fixed in svn 6578
User avatar (0003314)
ivan (administrator)
2010-07-18 15:05

Released in v3.62

- Issue History
Date Modified Username Field Change
2010-07-17 05:10 eckes New Issue
2010-07-17 09:33 ivan Note Added: 0003304
2010-07-17 09:33 ivan Status new => confirmed
2010-07-17 09:56 Tomse Status confirmed => assigned
2010-07-17 09:56 Tomse Assigned To => Tomse
2010-07-17 09:56 Tomse Target Version => 3.62 LTS
2010-07-17 12:02 Tomse Note Added: 0003308
2010-07-17 12:02 Tomse Status assigned => resolved
2010-07-17 12:02 Tomse Fixed in Version => Current SVN
2010-07-17 12:02 Tomse Resolution open => fixed
2010-07-18 15:05 ivan Note Added: 0003314
2010-07-18 15:05 ivan Status resolved => closed
2010-07-21 21:29 ivan Fixed in Version Current SVN => 3.62 LTS


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker