SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001376SiT!inbound emailpublic2010-08-05 10:242011-07-17 13:09
Reporternicdev 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.62 LTS 
Target Version3.63 LTSFixed in Version3.63 LTS 
Summary0001376: Importing "screenshots" fails when there is already an attachment to the inbound email.
DescriptionWhen importing an email with a screenshot in the body, and if the mail has no other attachments to it, the import works as intended -> The screenshot is seen in SiT as image00x.jpg.

But, if you import the same email, but add an attachment to it, the attachment is seen in SiT, but the "screenshot" is missing ...

I have tested this with several different amounts and sizes of attachments.

There are no errors in the debug file.
Additional InformationBecause i am a good OBF, it was my duty to check back on this to previous versions of SiT.
I can confirm that this bug has existed since at least version 3.60LTS.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0003345)
paulh (administrator)
2010-08-06 19:29

Can repro

also if an email has two images in the body you get:

Attachments: 2 - image001.jpg, image002.gif

Where image001.gif is the first image and image002.gif is the email itself
User avatar (0003346)
paulh (administrator)
2010-08-06 19:36

But don't seem to be able to reliably repro this in MTA mode (though can seemingly in IMAP)
User avatar (0003352)
nicdev (developer)
2010-08-09 08:47

Thanks Paul,

I did not mention but we are indeed using IMAP and Not MTA.
User avatar (0003506)
ivan (administrator)
2010-12-18 15:36

Fixed in svn r6812 and git 9cff794
User avatar (0003740)
ivan (administrator)
2011-04-16 15:07

Fix Released in 3.63

- Issue History
Date Modified Username Field Change
2010-08-05 10:24 nicdev New Issue
2010-08-06 19:29 paulh Note Added: 0003345
2010-08-06 19:29 paulh Status new => confirmed
2010-08-06 19:29 paulh Target Version => 3.63 LTS
2010-08-06 19:36 paulh Note Added: 0003346
2010-08-09 08:47 nicdev Note Added: 0003352
2010-12-18 13:16 ivan Status confirmed => assigned
2010-12-18 13:16 ivan Assigned To => ivan
2010-12-18 15:36 ivan Note Added: 0003506
2010-12-18 15:36 ivan Status assigned => resolved
2010-12-18 15:36 ivan Fixed in Version => Current SVN
2010-12-18 15:36 ivan Resolution open => fixed
2011-04-16 15:07 ivan Note Added: 0003740
2011-04-16 15:07 ivan Status resolved => closed
2011-07-17 13:09 ivan Fixed in Version Current SVN => 3.63 LTS


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker