SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001399SiT!LDAPpublic2010-09-14 17:212011-04-16 15:07
Reporterdipohl 
Assigned Topaulh 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.62 LTS 
Target Version3.63 LTSFixed in Version3.63 LTS 
Summary0001399: ldap_logindisabledattribute produces call of non-object in auto.php
Descriptionautorun.php tries to disable the account, which is not existing yet.

/usr/bin/php -f /opt/www/htdocs/sit/auto.php
PHP Fatal error: Call to a member function disable() on a non-object in /opt/www/htdocs/sit/auto.php on line 947
Steps To ReproduceHow to reproduce:
No contacts in database.
Define a ldap query for "LDAP Customer Group".
Have a user with "loginDisabled: TRUE"
Run auto.php with LDAP-Sync activated in scheduler.
Then autorun.php tries to disable the account, which is not existing yet.
-> Fatal PHP Error
Additional InformationI solved it for now, by changing the LDAP-match clause in
lib/ldap.inc.php to

Code: Select all
    define ('LDAP_EDIR_LOGINDISABLEDATTRIBUTE', '');


Then I run auto.php, which creates all contact accounts.
After that I changed the line in lib/ldap.inc.php back again:

Code: Select all
    define ('LDAP_EDIR_LOGINDISABLEDATTRIBUTE', 'loginDisabled');


After that the run of auto.php runs without error message.
I suppose, If in future we create a new user account and disable it before the next run of ldap-sync, then the error will appear again :-(

So it would be good, to solve the issue since then..
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0001424resolvedpaulh LDAP service tries to disable a customer who is already disabled and fails 

-  Notes
User avatar (0003414)
paulh (administrator)
2010-09-21 21:02

We have had something similar reported before (can't find the bug at the moment), need to investigate some more
User avatar (0003441)
paulh (administrator)
2010-10-16 12:31

can repro
User avatar (0003442)
paulh (administrator)
2010-10-16 12:42

r6734 and b0c685f resolve this
User avatar (0003718)
ivan (administrator)
2011-04-16 15:07

Fix Released in 3.63

- Issue History
Date Modified Username Field Change
2010-09-14 17:21 dipohl New Issue
2010-09-21 21:02 paulh Note Added: 0003414
2010-10-16 12:31 paulh Note Added: 0003441
2010-10-16 12:31 paulh Assigned To => paulh
2010-10-16 12:31 paulh Status new => confirmed
2010-10-16 12:42 paulh Note Added: 0003442
2010-10-16 12:42 paulh Status confirmed => resolved
2010-10-16 12:42 paulh Resolution open => fixed
2010-10-16 12:42 paulh Fixed in Version => 3.63 LTS
2010-10-16 12:42 paulh Target Version => 3.63 LTS
2011-02-10 09:59 paulh Relationship added has duplicate 0001424
2011-04-16 15:07 ivan Note Added: 0003718
2011-04-16 15:07 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker