SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001409SiT!schedulerpublic2010-10-02 22:362011-04-16 15:07
ReporterTomse 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformBSDOSFreeBSDOS Version6.4+Later
Product VersionCurrent SVN 
Target Version3.63 LTSFixed in VersionCurrent GIT 
Summary0001409: Scheduled job that takes longer than next auto.php execution, will have it's start time moved
Descriptionif a job takes longer time to run than the next execution of auto.php it'll move it's start time.

example: if tms_backup takes 1½ minute to run, and it's very first run is at 23:00. then the next run would be 23:01, the run after that 23:02.

I guess this is pr design because of the jobs running every minute.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001408new When job takes longer than time-to-next run of auto.php it's detected as missed 

-  Notes
User avatar (0003502)
ivan (administrator)
2010-12-18 12:52

Fixed in svn r6804 and Git d95703a
User avatar (0003505)
ivan (administrator)
2010-12-18 14:31

svn r6806, 6808 and 6809 also contain fixes for this.
User avatar (0003741)
ivan (administrator)
2011-04-16 15:07

Fix Released in 3.63

- Issue History
Date Modified Username Field Change
2010-10-02 22:36 Tomse New Issue
2010-10-02 22:36 Tomse Relationship added related to 0001408
2010-12-18 12:10 ivan Status new => assigned
2010-12-18 12:10 ivan Assigned To => ivan
2010-12-18 12:10 ivan Target Version => 3.63 LTS
2010-12-18 12:52 ivan Note Added: 0003502
2010-12-18 12:52 ivan Status assigned => resolved
2010-12-18 12:52 ivan Fixed in Version => Current GIT
2010-12-18 12:52 ivan Resolution open => fixed
2010-12-18 14:31 ivan Note Added: 0003505
2011-04-16 15:07 ivan Note Added: 0003741
2011-04-16 15:07 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker