SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000144SiT!inbound emailpublic2008-08-12 17:372008-11-21 17:27
Reporteruser13 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.33 
Target Version3.40Fixed in Version3.40 
Summary0000144: js function confirm_delete() in review_incoming_updates.php has unbalanced quotes
DescriptionOn the review_incoming_updates.php page, the checkboxes do not work due to unbalanced quotes in the confirm_delete() function.

The version in the code is this:

        function confirm_delete()
        {
            return window.confirm('<?php echo $strAreYouSureDelete; ?>");
        }

(note window.confirm call starts with apostrophe and ends with doublequotes)

it should be this:

        function confirm_delete()
        {
            return window.confirm("<?php echo $strAreYouSureDelete; ?>");
        }


TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000059)
kieran (administrator)
2008-08-12 17:59

Which version is this in? Looks to be fixed in svn and probably 3.36.
User avatar (0000060)
ivan (administrator)
2008-08-13 14:02

We should not have been using confirm_delete() in any case since this function was obsoleted and replaced by confirm_action(). I've fixed that in svn trunk r3900 and tested, this problem no longer exists.

Thanks for the bug report.

- Issue History
Date Modified Username Field Change
2008-08-12 17:37 user13 New Issue
2008-08-12 17:59 kieran Note Added: 0000059
2008-08-13 14:02 ivan Note Added: 0000060
2008-08-13 14:02 ivan Status new => resolved
2008-08-13 14:02 ivan Resolution open => fixed
2008-08-13 14:02 ivan Assigned To => ivan
2008-08-13 14:02 ivan Fixed in Version => 3.40
2008-08-13 14:02 ivan Target Version => 3.40
2008-08-13 14:02 ivan Description Updated
2008-11-21 17:27 kieran Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker