SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001462SiT!incidentspublic2011-02-16 20:282011-04-08 14:33
Reportersancho78rus 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.62 LTS 
Target VersionFixed in Version 
Summary0001462: Incidents goes to waiting queue after update
Descriptionsteps:
1) update incident: status=waiting customer action, next action time=hh:mm
after this incident goes to waiting queue
2) when hh:mm become and you whant to make simple update to incident (for example jast type tehnical details) - status is still waiting customer action. and if you forget to change it to Active - it goes to waiting queue again.
but i think that its wrong - it shoul stay in active queue. when incident returns from waiting queue its status should change to active automaticaly.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000037confirmed Regular contact days is flawed 

-  Notes
User avatar (0003630)
ivan (administrator)
2011-02-22 15:06

I disagree. The status of the incident hasn't changed, it is true that you are still waiting for the customer.
(0003632)
sancho78rus (reporter)
2011-02-22 15:39

yes - there can be situations when status need to be unchanged. but if it should be active and you forget to change it to active - it will never return to active queue.
i mean that mistake when incident in active queue is better than mistake when incident in waiting queue.
User avatar (0003633)
nicdev (developer)
2011-02-22 17:07

Ivan,

I have to agree with you here. The "Status" (like Awaiting Customer") exists seperately and describes the state the incidnet is in ... it can be waiting for the customer AND at the same time be in the "Waiting queue".

We use this a lot to put an incident "away" for a while (which means it disappears from the User's Dashlet), and when the hh:mm arrives, it appears on his list again, BUT it must not change status as it is still in the same state ... if it changed to "Active" automatically it messes the statistics and reports up, because our engineer may not notice it has changed to Active, and/or he may forget to change it back to "Awaiting customer".
User avatar (0003671)
ivan (administrator)
2011-03-08 10:37

This is working as designed so I don't plan to change this. If we're ever going to change this it needs a good open discussion first. The forum is probably the best place for that to happen.

- Issue History
Date Modified Username Field Change
2011-02-16 20:28 sancho78rus New Issue
2011-02-22 15:06 ivan Note Added: 0003630
2011-02-22 15:39 sancho78rus Note Added: 0003632
2011-02-22 17:07 nicdev Note Added: 0003633
2011-02-22 17:23 ivan Relationship added related to 0000037
2011-03-08 10:37 ivan Note Added: 0003671
2011-03-08 10:37 ivan Status new => resolved
2011-03-08 10:37 ivan Resolution open => won't fix
2011-03-08 10:37 ivan Assigned To => ivan
2011-04-08 14:32 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker