SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001480SiT!SLAspublic2011-03-07 15:372011-07-17 13:09
Reporterluca 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.62 LTS 
Target Version3.63 LTSFixed in Version3.63 LTS 
Summary0001480: service level timings are wrongly calculated if the working hours aren't 8.
Descriptionhttp://sitracker.org/forum/viewtopic.php?f=4&t=1417357 [^]

having a 9 hours working day (9-18) if i put 3 days in the resolution field i get only 2 days 6 hours shown (1 per day missing). Switching back to an 8 workinghours day it shows up correctly.

Additional InformationWould be nice having the option to put a break time in too, at least it's duration.
I have a 9 hours workday but in fact SLAs should be calculated on 8 hours due to the midday break.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0003669)
ivan (administrator)
2011-03-08 10:34

Thanks for the bug report.
User avatar (0003678)
paulh (administrator)
2011-03-11 19:56

Confirm this is an issue, it only effects resolution/reprioritisation line 55 of service_levels.php has a hard coded 480 for number of mins in a working day
User avatar (0003679)
paulh (administrator)
2011-03-11 20:00

r7016 and 7c67577 resolve
User avatar (0003725)
ivan (administrator)
2011-04-16 15:07

Fix Released in 3.63

- Issue History
Date Modified Username Field Change
2011-03-07 15:37 luca New Issue
2011-03-08 10:34 ivan Note Added: 0003669
2011-03-08 10:34 ivan Status new => acknowledged
2011-03-11 19:56 paulh Note Added: 0003678
2011-03-11 19:56 paulh Assigned To => paulh
2011-03-11 19:56 paulh Status acknowledged => confirmed
2011-03-11 19:56 paulh Target Version => 3.63 LTS
2011-03-11 20:00 paulh Note Added: 0003679
2011-03-11 20:00 paulh Status confirmed => resolved
2011-03-11 20:00 paulh Resolution open => fixed
2011-03-11 20:00 paulh Fixed in Version => Current SVN
2011-04-16 15:07 ivan Note Added: 0003725
2011-04-16 15:07 ivan Status resolved => closed
2011-07-17 13:09 ivan Fixed in Version Current SVN => 3.63 LTS


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker