SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001509SiT!otherpublic2011-05-11 10:082011-07-17 14:25
Reporterivan 
Assigned Toivan 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.64 LTSFixed in Version3.64 LTS 
Summary0001509: SiT! 3.6x should refuse to run with 3.9x/4.x database schema
DescriptionSiT! 3.6x should refuse to run with 3.9x/4.x database schema. We should print a message/warning advising an upgrade.

This is to prevent downgrades from 3.90/4.x to 3.6x because I suspect that will cause problems.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0003786)
paulh (administrator)
2011-05-27 19:23

Agree, this should probably be eben more generic in that sit shouldn't run with a newer schema i.e. sit 4.0 can't run with a 4.1 schema
User avatar (0003799)
Tomse (developer)
2011-05-31 12:40

today we have a table "system" with a sit version, a suggestion to add a schema version to this table since it's not always that the schema is updated when a new version of SiT is updated.

how are your opinions on this ?
User avatar (0003804)
paulh (administrator)
2011-05-31 19:37

Thats an interesting point and brings us back to 1080 which is overhauling the schema.

One thing I proposed was decoupling the schema version from that of SiT though views where mixed. I'd like to get away from how we currently handle schema as its a real pain if your running a dev version though we've not managed to come up with a clean way of doing it yet that doesn't add become unworkable, if you have any thoughts let me know
User avatar (0003805)
Tomse (developer)
2011-05-31 20:38

My initial thought/idea was adding a schema version for the release version of SiT if there was a change.
i.e. 3.40 for SiT v3.40, and since there was no schema change from SiT v3.40 to v3.41 the schema version would still be v3.40 (hope it makes sense)

but in regards to dev version perhaps it should be incremental, kinda like when upgrading dashlets.

this is the overview.. the mechanics behind could become "complex", by each change in the database you'd also have an according section in the schema-setup, this would make schema-setup messy in accord to alphabetical order, but much easier to do when upgrading and/or adding new database changes, since it would basically just be "add a new line to the end of the file"

I'm wondering if we should put this on the agenda for our next meeting ?
User avatar (0004108)
ivan (administrator)
2011-07-17 12:20
edited on: 2011-07-17 12:20

Added a message to 3.64

"IMPORTANT: The SiT! database schema has been updated for use with later version of SiT! than is currently running, you are likely to experience instability. Please upgrade to SiT! 3.90 or later."

The explicitly checks for schema 3.90 or later. I think we could definitely handle this better in future. I'm reluctant to say that any later schema cannot be used though because in the majority of cases that's not much of a problem.

SVN r7240

User avatar (0004125)
ivan (administrator)
2011-07-17 14:25

Fix released in version 3.64 available now

- Issue History
Date Modified Username Field Change
2011-05-11 10:08 ivan New Issue
2011-05-27 19:23 paulh Note Added: 0003786
2011-05-27 19:23 paulh Status new => confirmed
2011-05-27 20:11 paulh Target Version => 3.64
2011-05-31 12:40 Tomse Note Added: 0003799
2011-05-31 19:37 paulh Note Added: 0003804
2011-05-31 20:38 Tomse Note Added: 0003805
2011-06-14 11:50 ivan Target Version 3.64 => 3.64 LTS
2011-07-17 12:20 ivan Note Added: 0004108
2011-07-17 12:20 ivan Note Edited: 0004108 View Revisions
2011-07-17 12:21 ivan Status confirmed => resolved
2011-07-17 12:21 ivan Fixed in Version => Current SVN
2011-07-17 12:21 ivan Resolution open => fixed
2011-07-17 12:21 ivan Assigned To => ivan
2011-07-17 13:14 ivan Fixed in Version Current SVN => 3.64 LTS
2011-07-17 14:25 ivan Note Added: 0004125
2011-07-17 14:25 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker