SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001645SiT!LDAPpublic2011-07-07 21:492013-02-10 16:30
ReporterTomse 
Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version3.63p1 
Target VersionFixed in Version 
Summary0001645: LDAP OU's with spaces causes problems on Win2008
Descriptionref: http://sitracker.org/forum/viewtopic.php?f=4&t=1417404 [^]

quote from darkfall from the same forum post:

For testing, SiT is running on Windows 2008 R2 with XAMPP installed and configured. My LDAP integration working properly, except with LDAP requests containg AD tree (OUs) with spaces. I know this is not supported by SiT, but this is a critical part for us.

i searched on php.net, et found an "easy" solution for managing spaces.

[quote from php.net]
When I discovered I couldn't get searches to work with complex strings (in my case searching on displayName which can have parens and slashes in it). I made this quick function to quote ldap strings in accordance with the RFC. Except I encode spaces as well since searching wouldn't work with spaces. Note, technically speaking a search filter can be encoded into the \xx format for all characters but then filters wouldn't be human readable.

I'm somewhat surprised there wasn't a built in ldap_quote() type of function already.
<?php
// see: RFC2254
function ldap_quote($str) {
return str_replace(
array( '\\', ' ', '*', '(', ')' ),
array( '\\5c', '\\20', '\\2a', '\\28', '\\29' ),
$str
);
}[/quote]

Is that possible to modify part of code to add this function and link all ldap variables through this function? i tried to integrate code by myself (ldap.inc.php), but i failed ;)
Tagspatch
Attached Files

- Relationships

-  Notes
User avatar (0004137)
paulh (administrator)
2011-08-05 19:35

I've tested the current got branch with Windows 2008r2 and have OUs with spaces in them and don't get a problem.

This is with PHP5.3 and without this additional code, need to test 3.x against Windows2008.

Perhaps its a problem due to the underlying OS (Windows, my tests with Linux)?
User avatar (0004215)
paulh (administrator)
2011-08-13 19:15

Just tested sit3.x against my 2008 server and spares don't seem to be a problem my users are in:

OU=SiT Test,DC=ph-ad,DC=work,DC=EXAMPLE,DC=co,DC=uk

Can anyone else reproduce this?
(0004402)
shadlan (reporter)
2012-01-10 17:29

Hello.

I tried to configure sit3.x with our 2003r2 server with spaces in OU and CN without luck. I have SiT! running in a Linux VM with TurnKey Linux LAMP installed.
User avatar (0004702)
paulh (administrator)
2013-02-10 16:30

I've tested this one again and am unable to reproduce this problem with spaces in either container or CN, is any one able to provide more details steps to reproduce?

- Issue History
Date Modified Username Field Change
2011-07-07 21:49 Tomse New Issue
2011-07-07 21:59 ivan Tag Attached: patch
2011-08-05 19:35 paulh Note Added: 0004137
2011-08-05 19:35 paulh Status new => feedback
2011-08-13 19:15 paulh Note Added: 0004215
2012-01-10 17:29 shadlan Note Added: 0004402
2013-02-10 16:30 paulh Note Added: 0004702


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker