SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001685SiT!userspublic2011-08-12 10:042011-09-04 20:45
Reportermartian 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSLinuxOS Version2.6+later
Product Version3.64 LTS 
Target Version3.65 LTSFixed in Version3.65 LTS 
Summary0001685: Cannot edit user email
DescriptionIf a mistake is made entering a user's email address it cannot be subsequently edited. This may not be noticed for months until the user needs to reset their password at which point they cannot receive the reset email.

At this point, they cannot reset their password and neither can an administrator reset it for them. The admin can also not edit the email address in their record nor can they delete the user so as to recreate them.

The only thing that can be done to get a reset password mail delivered to the user is to go into the database and hand edit their record so as to change the email address.
TagsNo tags attached.
Attached Filespng file icon sit-screenshot.png [^] (59,035 bytes) 2011-08-12 10:41


? file icon user_profile_edit.php [^] (20,069 bytes) 2011-08-12 11:10

- Relationships

-  Notes
(0004201)
martian (reporter)
2011-08-12 11:02

Note from IRC:

<martian_> it's when *I* am logged on as an ldap user (admin) I cannot edit the email
<martian_> when I log on with my SiT username I can

So the issue only affects the LDAP admin who is editing users
User avatar (0004202)
ivan (administrator)
2011-08-12 11:09

Looks like the code checks the source in the users session rather than the source of the user being edited, so if the user who is doing the editing has a source of LDAP he/she will not be able to edit some fields of another users profile.
User avatar (0004203)
ivan (administrator)
2011-08-12 11:11

I've attached a file user_profile_edit.php to this bug report, can you make a backup of your existing file and then try putting this one into your SiT! folder to see if it fixes the problem?
(0004204)
martian (reporter)
2011-08-12 11:47

The new user_profile_edit.php fixes the edit problem
User avatar (0004205)
ivan (administrator)
2011-08-12 12:02

Fixed in svn r7252 and Git 9419228:

We now check the user source as stored in the database rather than the user session because user_profile_edit can be used by administrators to edit other users, it's not soley used for editing your own profile.
User avatar (0004291)
ivan (administrator)
2011-09-04 20:45

Fix released in v3.65

- Issue History
Date Modified Username Field Change
2011-08-12 10:04 martian New Issue
2011-08-12 10:41 martian File Added: sit-screenshot.png
2011-08-12 11:02 martian Note Added: 0004201
2011-08-12 11:03 ivan Status new => confirmed
2011-08-12 11:03 ivan Target Version => 3.65 LTS
2011-08-12 11:09 ivan Note Added: 0004202
2011-08-12 11:10 ivan File Added: user_profile_edit.php
2011-08-12 11:11 ivan Note Added: 0004203
2011-08-12 11:47 martian Note Added: 0004204
2011-08-12 11:57 ivan Assigned To => ivan
2011-08-12 11:57 ivan Status confirmed => assigned
2011-08-12 12:02 ivan Note Added: 0004205
2011-08-12 12:02 ivan Status assigned => resolved
2011-08-12 12:02 ivan Fixed in Version => Current SVN
2011-08-12 12:02 ivan Resolution open => fixed
2011-09-04 17:37 ivan Fixed in Version Current SVN => 3.65 LTS
2011-09-04 20:45 ivan Note Added: 0004291
2011-09-04 20:45 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker