SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001691SiT!incidentspublic2011-08-18 11:022011-09-04 20:45
Reporterivan 
Assigned Topaulh 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.64 LTS 
Target Version3.65 LTSFixed in Version3.65 LTS 
Summary0001691: External ID value changed upon editing an incident
DescriptionAs reported in this forum post http://sitracker.org/forum/viewtopic.php?f=4&t=1417422 [^]

When editing an incident an external ID entered as a very large integer is changed upon saving. e.g. "4633485881" is saved as "2147483647"




Additional InformationI had a quick look at the code and it seems we use clean_int() for this form variable which looks like a mistake to me.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0004236)
paulh (administrator)
2011-08-19 19:57

Confirming, we should support external IDs which are not numeric

(Incidentally if your server is 64bit you don't get this problem, well not until really big numbers, hence why I can't reproduce)
User avatar (0004237)
paulh (administrator)
2011-08-19 20:02

r7260 and f699ea6 resolve this, we now do clean_dbstring
User avatar (0004288)
ivan (administrator)
2011-09-04 20:45

Fix released in v3.65

- Issue History
Date Modified Username Field Change
2011-08-18 11:02 ivan New Issue
2011-08-19 19:57 paulh Note Added: 0004236
2011-08-19 19:57 paulh Assigned To => paulh
2011-08-19 19:57 paulh Status new => confirmed
2011-08-19 20:02 paulh Note Added: 0004237
2011-08-19 20:02 paulh Status confirmed => resolved
2011-08-19 20:02 paulh Resolution open => fixed
2011-08-19 20:02 paulh Fixed in Version => Current SVN
2011-09-04 17:37 ivan Fixed in Version Current SVN => 3.65 LTS
2011-09-04 20:45 ivan Note Added: 0004288
2011-09-04 20:45 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker