SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001714SiT!incidentspublic2011-09-06 09:502012-07-07 18:10
Reporternicdev 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.65 LTS 
Target Version3.66 LTSFixed in Version3.66 LTS 
Summary0001714: When opening an incident for viewing: Application Warning [512] Unexpected input (in line 382 of file base.inc.php)
DescriptionIt seems that whenever you open an incident to view or edit it, this message appears in the debug log:
2011-09-06T10:34:26+02:00 incident_details.php Application Warning [512] Unexpected input (in line 382 of file base.inc.php)


I'm not sure this is really a bug, but it can fill up the log quite a bit on a busy site.
Additional InformationThe reason is that the function "clean_fixed_list()" in line 24 of incident_details.php is trying to clean a value that is not in the list ..

$win = clean_fixed_list($_REQUEST['win'], array('','incomingview', 'jump', 'holdingview', 'sit_popup'));
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0004304)
paulh (administrator)
2011-09-20 20:21

Fixed this in r7406, incidentNUMBER added to the list, in 4.x we just use sit_popup so not ported to git

- Issue History
Date Modified Username Field Change
2011-09-06 09:50 nicdev New Issue
2011-09-06 10:36 ivan Status new => confirmed
2011-09-20 20:21 paulh Note Added: 0004304
2011-09-20 20:21 paulh Assigned To => paulh
2011-09-20 20:21 paulh Status confirmed => resolved
2011-09-20 20:21 paulh Resolution open => fixed
2011-09-20 20:21 paulh Target Version => 3.66 LTS
2011-09-20 20:21 paulh Fixed in Version => Current SVN
2012-07-06 14:13 Tomse Fixed in Version Current SVN => 3.66 LTS
2012-07-07 18:10 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker