SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000198SiT!triggerspublic2008-10-28 18:042009-02-27 16:25
Reporterpaulh 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.45Fixed in Version3.45 
Summary0000198: Trigger error after approving a billable incident
DescriptionAfter approving a billable incident we get the following error

Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/paul/sit/includes/triggers.inc.php(301) : eval()'d code on line 1

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/paul/sit/includes/triggers.inc.php(301) : eval()'d code on line 1

Parse error: syntax error, unexpected ';' in /home/paul/sit/includes/triggers.inc.php(301) : eval()'d code on line 1
TagsNo tags attached.
Attached Files

- Relationships
related to 0000148closedkieran Need a trigger when a site drops below a certain percent of the service 

-  Notes
User avatar (0000145)
kieran (administrator)
2008-10-28 21:30

I remember trying to find the cause of this ages ago. Will have another look tomorrow.
User avatar (0000146)
kieran (administrator)
2008-10-29 14:54

removed from the code for 3.40 unless I can find a solution.
User avatar (0000602)
ivan (administrator)
2009-02-09 16:59

Have committed an attempt to fix this in trunk svn r5033, Paul could you test and update this bug with the results. - Thanks.
User avatar (0000603)
ivan (administrator)
2009-02-09 17:06

Paul,

We're also going to need some Documentation on billing, I know it's a pain when you're busy, but I'm unable to test this because I simply can't work out how to get anything to appear in the list of things to approve. I've tried adding lots of activity and closing incidents and everything I can think of, can't work it out.

Ivan
User avatar (0000604)
paulh (administrator)
2009-02-09 19:18

Unfortunately the fix hasn't work I still get:

Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/paulh/sit/lib/triggers.inc.php(323) : eval()'d code on line 1

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/paulh/sit/lib/triggers.inc.php(323) : eval()'d code on line 1

Parse error: syntax error, unexpected ';' in /home/paulh/sit/lib/triggers.inc.php(323) : eval()'d code on line 1

As for the documentation I simply don't have the time at the moment though the steps to reproduce this are:

* Create incident against a timed contract
* Create an activity
* Close the activity
* Close the call
* Approve the incident (Maintenance -> Billing -> Approve)

Have you updated to the latest schema? As the way this is handled has changed dramatically recently which is why I suspect your not seeing anything in the list
User avatar (0000607)
ivan (administrator)
2009-02-10 15:16

Taking another look
User avatar (0000621)
ivan (administrator)
2009-02-12 16:14

The trigger call does not pass the siteid which is required by the template variable {salespersonemail}
User avatar (0000626)
ivan (administrator)
2009-02-13 11:07

The trigger call is

trigger('TRIGGER_SERVICE_LIMIT', array('contractid' => $maintid, 'serviceremaining' => $percent));

So it's passing, contractid, and serviceremaining. For the template variable {salespersonemail} to work, siteid is also required to be passed. Alternatively a new variable handler for {salespersonemail} needs adding that requires contractid and looks up the siteid from that.
User avatar (0000672)
ivan (administrator)
2009-02-26 18:01

Fixed in trunk svn r5211

- Issue History
Date Modified Username Field Change
2008-10-28 18:04 paulh New Issue
2008-10-28 21:30 kieran Note Added: 0000145
2008-10-28 21:30 kieran Assigned To => kieran
2008-10-28 21:30 kieran Status new => confirmed
2008-10-29 14:54 kieran Note Added: 0000146
2008-10-29 14:54 kieran Target Version 3.40 => 3.45
2008-11-29 23:32 kieran Target Version 3.45 => 3.50
2008-12-04 13:37 kieran Relationship added related to 0000148
2008-12-04 13:38 kieran Target Version 3.50 => 3.45
2009-02-09 16:59 ivan Note Added: 0000602
2009-02-09 16:59 ivan Assigned To kieran => ivan
2009-02-09 16:59 ivan Status confirmed => feedback
2009-02-09 17:06 ivan Note Added: 0000603
2009-02-09 19:18 paulh Note Added: 0000604
2009-02-10 15:16 ivan Note Added: 0000607
2009-02-10 15:16 ivan Status feedback => assigned
2009-02-12 16:14 ivan Note Added: 0000621
2009-02-12 16:29 ivan Assigned To ivan => paulh
2009-02-13 11:07 ivan Note Added: 0000626
2009-02-26 17:49 ivan Assigned To paulh => ivan
2009-02-26 18:01 ivan Note Added: 0000672
2009-02-26 18:01 ivan Status assigned => resolved
2009-02-26 18:01 ivan Resolution open => fixed
2009-02-26 18:01 ivan Fixed in Version => Current SVN
2009-02-27 13:54 ivan Fixed in Version Current SVN => 3.45
2009-02-27 16:25 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker