SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000209SiT!setup/configpublic2008-11-05 16:052008-11-21 17:26
Reporterivan 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.40Fixed in Version3.40 
Summary0000209: Upgrade schema fails 3.35 to 3.40
DescriptionUpdating schema from 3.32 to v3.35…

Schema successfully updated to version 3.35.

Updating schema from 3.35 to v3.40…

A MySQL error occurred: [1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''triggerid', 'userid', 'action', 'template', 'parameters', 'checks') VALUES('TRI' at line 1
You may have found a bug, if you think this is the case please report it.
Raw SQL: INSERT INTO `triggers` ('triggerid', 'userid', 'action', 'template', 'parameters', 'checks') VALUES('TRIGGER_SERVICE_LIMIT', 0, 'ACTION_EMAIL', 'EMAIL_SERVICE_LEVEL', '', '{serviceremaining} <= 0.2') -- KMH 2008-10-08 INSERT INTO `scheduler` (`action`, `params`, `paramslabel`, `description`, `status`, `start`, `end`, `interval`, `lastran`, `success`) VALUES ('CheckIncomingMail', '', NULL, 'Check incoming support mailbox.', 'enabled', '2008-01-01 00:00:00', '0000-00-00 00:00:00', 60, '0000-00-00 00:00:00', 1)

1 Error(s) occurred while updating the schema, please resolve the problems reported and then try running setup again.

Application Error [256]
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '; UPDATE `triggers` SET `checks` = REPLACE(`checks`, ')', '')' at line 1 in /home/ivan/dev1/sit/trunk/htdocs/setup.php @ line 1087

You may have found a bug in SiT, please report it.

See the doc/UPGRADE file for further upgrade instructions and help.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000164)
kieran (administrator)
2008-11-05 19:45

Fixed in trunk r4160.
User avatar (0000165)
kieran (administrator)
2008-11-05 19:47

Ivan, it looks like there's two SQL errors here, the latter with the checks SQL which worked for me. Can you try r4160 and see if you can still repro the latter error?
User avatar (0000188)
ivan (administrator)
2008-11-13 07:55

At r4183 I can still reproduce this.
User avatar (0000189)
ivan (administrator)
2008-11-13 08:12

Fixed in trunk r4184, there were some missing semi-colons and missing single quotes.

- Issue History
Date Modified Username Field Change
2008-11-05 16:05 ivan New Issue
2008-11-05 19:45 kieran Note Added: 0000164
2008-11-05 19:45 kieran Assigned To => kieran
2008-11-05 19:45 kieran Status new => resolved
2008-11-05 19:45 kieran Resolution open => fixed
2008-11-05 19:45 kieran Fixed in Version => 3.40
2008-11-05 19:47 kieran Note Added: 0000165
2008-11-05 19:47 kieran Status resolved => feedback
2008-11-13 07:55 ivan Note Added: 0000188
2008-11-13 07:55 ivan Status feedback => assigned
2008-11-13 07:55 ivan Assigned To kieran => ivan
2008-11-13 08:12 ivan Note Added: 0000189
2008-11-13 08:12 ivan Status assigned => resolved
2008-11-21 17:26 kieran Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker