SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000240SiT!contractspublic2008-11-21 14:472009-02-27 16:28
Reporterivan 
Assigned Toivan 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.40 
Target Version3.45Fixed in Version3.45 
Summary0000240: Changing the product assigned to a contract breaks the contract
DescriptionIf you edit a contract and change the product, when you save you're returned to a page that has the following warning and a blank table. Furthermore the contract is no longer listed in browse contracts and effectively disappears.

Application Warning [512]
No Contracts Found: 3 in /home/ivan/dev1/sit/trunk/includes/functions.inc.php @ line 8420
Backtrace:
/home/ivan/dev1/sit/trunk/includes/functions.inc.php @ line 8420 trigger_error()
/home/ivan/dev1/sit/trunk/htdocs/contract_details.php @ line 30 contract_details()
Additional InformationLicenseType and ServiceLevelID seem to get lost
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000260)
ivan (administrator)
2008-12-03 18:00

I need to check this with latest svn
User avatar (0000300)
ivan (administrator)
2008-12-08 12:44

Not a problem for trunk svn r4403
User avatar (0000303)
ivan (administrator)
2008-12-08 14:06

reproduced by myself and stonekeeper. Now after an edit you get "Nothing to Display" but it only seems to happen on certain contracts
User avatar (0000304)
ivan (administrator)
2008-12-08 14:45

Editing a contract sets licence_type to 0 (rather than null) which then breaks the display
User avatar (0000305)
ivan (administrator)
2008-12-08 15:16

Fixed in svn trunk r4411 ready for 3.45 release

- Issue History
Date Modified Username Field Change
2008-11-21 14:47 ivan New Issue
2008-11-21 14:48 ivan Additional Information Updated
2008-12-03 18:00 ivan Note Added: 0000260
2008-12-03 18:00 ivan Assigned To => ivan
2008-12-03 18:00 ivan Status new => feedback
2008-12-08 12:44 ivan Note Added: 0000300
2008-12-08 12:44 ivan Status feedback => closed
2008-12-08 12:44 ivan Resolution open => unable to reproduce
2008-12-08 14:06 ivan Note Added: 0000303
2008-12-08 14:06 ivan Status closed => feedback
2008-12-08 14:06 ivan Resolution unable to reproduce => reopened
2008-12-08 14:45 ivan Note Added: 0000304
2008-12-08 14:45 ivan Status feedback => assigned
2008-12-08 14:45 ivan Resolution reopened => open
2008-12-08 14:45 ivan Target Version => 3.45
2008-12-08 15:16 ivan Note Added: 0000305
2008-12-08 15:16 ivan Product Version => 3.40
2008-12-08 15:16 ivan Fixed in Version => 3.45
2008-12-08 15:16 ivan Status assigned => resolved
2008-12-08 15:16 ivan Resolution open => fixed
2009-02-27 16:28 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker