SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000278SiT!incidentspublic2008-12-03 10:332009-02-27 16:25
Reporternicdev 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.45Fixed in Version3.45 
Summary0000278: Finding contracts when adding incidents does not find "Pan, Peter"
DescriptionClick "create" for a new mail in the holding queue, then
 
It does not recognise the contact if it exists because it looks for Peter, Pan and not Pan, Peter ..

The ordering of the last name first then the first name confuses the search.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000342)
ivan (administrator)
2008-12-13 21:54

Bumping this one to v3.45 as this would require some major reworking of the SQL that does the name lookup which we'd rather not do for a release such as 3.41 which is minor in focus.

The risk is that the changes might introduce more bugs.
User avatar (0000422)
ivan (administrator)
2009-01-07 22:01

From v3.45 when finding incidents from incoming emails in the holding queue the email address is used as a hint rather than the name, this is much more reliable and probably makes this request redundant.

Just to check, you did mean the process of finding the correct person to log an incident to after an email has come in?

If so I think the name search method is mainly redundant now.
User avatar (0000434)
nicdev (developer)
2009-01-08 07:37

Hi Ivan, yes this is exactly what i meant, in fact we made a small code change to recognise Peter Pan and Pan Peter but we could not succeed to regognise the contact when we had just an email address: eg:

If the mail header had:
"Pan, Peter <peter.pan@company.com>" it was ok because the script recognised the contact correctly and
"Peter, Pan <peter.pan@company.com>" the script did not always find the contact and we changed the add incident script as below to repair that:

*******
// Filter by contact
    $contactsql .= "AND (c.surname LIKE '%$search_string%' OR c.forenames LIKE '%$search_string%' ";
    $contactsql .= "OR SOUNDEX('$search_string') = SOUNDEX(CONCAT_WS(' ', c.forenames, c.surname)) ";
    $contactsql .= "OR SOUNDEX('$search_string') = SOUNDEX(CONCAT_WS(' ', c.surname, c.forenames)) ";
    $contactsql .= "OR SOUNDEX('$search_string') = SOUNDEX(c.forenames) ";
    $contactsql .= "OR s.name LIKE '%$search_string%') ";
******

But if the header had just "ppan@company.com" it could not find the contact at all.

Hope that helps
User avatar (0000611)
ivan (administrator)
2009-02-11 16:12

Added to svn trunk r5064

- Issue History
Date Modified Username Field Change
2008-12-03 10:33 ivan New Issue
2008-12-03 10:33 ivan Reporter ivan => nicdev
2008-12-03 12:29 ivan Assigned To => ivan
2008-12-03 12:29 ivan Status new => assigned
2008-12-03 12:29 ivan Target Version => 3.41
2008-12-13 21:54 ivan Note Added: 0000342
2008-12-13 21:54 ivan Projection none => major rework
2008-12-13 21:54 ivan Target Version 3.41 => 3.45
2009-01-07 22:01 ivan Note Added: 0000422
2009-01-07 22:01 ivan Status assigned => feedback
2009-01-08 07:37 nicdev Note Added: 0000434
2009-01-28 15:24 paulh Status feedback => assigned
2009-02-11 16:12 ivan Note Added: 0000611
2009-02-11 16:12 ivan Status assigned => resolved
2009-02-11 16:12 ivan Resolution open => fixed
2009-02-11 16:12 ivan Fixed in Version => Current SVN
2009-02-27 13:54 ivan Fixed in Version Current SVN => 3.45
2009-02-27 16:25 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker