SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000029SiT!inbound emailpublic2008-07-11 16:052009-08-16 14:38
Reporteradministrator 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.36 
Target Version3.50Fixed in Version3.50 
Summary0000029: Inbound email strips HTML-like terms
DescriptionInbound email strips HTML-like terms Private: (?)
No

The following extract from an email submission to SiT:

====================================
The output filename varies depending on the enquiry type, and for a 'root'
path consisting of the log folder "\\<<Intempo server>>\BOS\Logs\<<proposal
id>>" will be one of the following:

<<root>>_All_ICBResponse.txt, <<root>>_Company_ICBResponse.txt,
<<root>>_Main Applicant_ICBResponse.txt, <<root>>_Joint Applicant
_ICBResponse.txt, <<root>>_Guarantor1_ICBResponse.txt,
<<root>>_Guarantor2_ICBResponse.txt, <<root>>_Guarantor3_ICBResponse.txt,
<<root>>_Director1_ICBResponse.txt, <<root>>_Director2_ICBResponse.txt,
====================================

Had the terms inside angle brackets stripped and subsequently appeared as
follows:

====================================
The output filename varies depending on the enquiry type, and for a
'root' path consisting of the log folder "\\<
server>>\BOS\Logs\<>" will be one of the following:

<>_All_ICBResponse.txt, <>_Company_ICBResponse.txt,
<>_Main Applicant_ICBResponse.txt, <>_Joint Applicant
_ICBResponse.txt, <>_Guarantor1_ICBResponse.txt,
<>_Guarantor2_ICBResponse.txt,
<>_Guarantor3_ICBResponse.txt, <>_Director1_ICBResponse.txt,
<>_Director2_ICBResponse.txt,
====================================
Additional InformationDate: 2008-05-15 12:36
Sender: ivanlucasProject Admin
Logged In: YES
user_id=1456679
Originator: NO

This is always difficult because you can never been sure whether you want
to strip the text that looks like tags or leave it in, the reason is
because some HTML clients send HTML as plain text and if we simply allowed
it through it would look terrible in the incident log.

We should try and resolve this for 3.40 at the latest
                            

Date: 2008-05-15 11:54
Sender: marsbard
Logged In: YES
user_id=13803
Originator: YES

My mistake, the algorithm I posted isn't suitable; however it is good for
removing the inside bits of blocks like <script></script>
                            

Date: 2008-05-15 11:48
Sender: marsbard
Logged In: YES
user_id=13803
Originator: YES


This looks like a good algorithm:
http://nadeausoftware.com/articles/2007/09/php_tip_how_strip_html_tags_web_page [^]
                            

Date: 2008-05-13 22:29
Sender: kieran_hogg
Logged In: YES
user_id=1872958
Originator: NO

This was done by design, to prevent crappy html emails messing up the
incident logs, but perhaps we need to strip out actual html tags rather
than using one of the inbuilt functions to clean the input. I /believe/
there may be a function that only strips out valid html tags, I remember
seeing it somewhere, if not, we need to write one.
                            
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000620closedivan Text within < and > is stripped from incoming emails 

-  Notes
User avatar (0000928)
ivan (administrator)
2009-04-17 14:50

Fixed in trunk svn r5329
User avatar (0001616)
ivan (administrator)
2009-08-16 14:38

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2008-07-11 16:05 administrator New Issue
2008-10-29 15:00 ivan Status new => confirmed
2008-10-29 15:00 ivan Product Version => 3.36
2008-10-29 15:00 ivan Target Version => 3.45
2008-11-29 23:32 kieran Target Version 3.45 => 3.50
2009-04-17 14:40 ivan Relationship added has duplicate 0000620
2009-04-17 14:50 ivan Note Added: 0000928
2009-04-17 14:50 ivan Assigned To => ivan
2009-04-17 14:50 ivan Status confirmed => resolved
2009-04-17 14:50 ivan Resolution open => fixed
2009-04-17 14:50 ivan Fixed in Version => Current SVN
2009-08-16 13:17 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:38 ivan Note Added: 0001616
2009-08-16 14:38 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker