SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000030SiT!inbound emailpublic2008-07-11 16:072008-11-21 22:04
Reporteradministrator 
Assigned Tokieran 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.40 
Summary0000030: Inbound emails w/o incident no store attachments incorrectly
DescriptionInbound emails w/o incident no store attachments incorrectly Private: (?)
No

When an email is received via the inboundemail.php script and has an
attachment the attachment is stored incorrectly. For example, an inbound
email with an attachment is assigned to an existing incident. When viewing
the incident and clicking on the attachment, the following error message is
shown: "The requested URL
/attachments/updates/2317/apto_2008-05-13_01h01m.Tuesday.sql.gz was not
found on this server.", however the attachment is to be found in
attachments/1210637177/apto_2008-05-13_01h01m.Tuesday.sql.gz

In the first path the number 2317 is the database id of the update. In the
second path the number 1210637177 appears to be the unix time of arrival of
the email.
Additional InformationDate: 2008-05-30 10:27
Sender: kieran_hogg
Logged In: YES
user_id=1872958
Originator: NO

Fixes commited in trunk r3359, needs testing.
                            

Date: 2008-05-13 22:32
Sender: kieran_hogg
Logged In: YES
user_id=1872958
Originator: NO

Yep, attachments currently use a mish-mash of formats. This will almost
certainly be fixed in the next release as it blocks finishing the portal
files section which was slated for this release.
                            
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0000006closedkieran Inbound emails w/o incident no store attachments incorrectly 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-07-11 16:07 administrator New Issue
2008-07-11 16:08 administrator Status new => resolved
2008-07-11 16:08 administrator Resolution open => fixed
2008-07-11 16:08 administrator Assigned To => administrator
2008-07-11 16:33 ivan Status resolved => assigned
2008-07-11 16:33 ivan Assigned To administrator => kieran
2008-07-11 16:34 ivan Status assigned => resolved
2008-10-29 11:15 ivan Relationship added duplicate of 0000006
2008-11-21 22:04 kieran Status resolved => closed
2008-11-21 22:04 kieran Fixed in Version => 3.40


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker