SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000322SiT!otherpublic2008-12-12 16:052010-03-04 17:38
Reporterpaulh 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.41Fixed in Version3.41 
Summary0000322: bbcode [[att = should be optional
Descriptionbbcode [[att = should be optional
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000336)
paulh (administrator)
2008-12-13 10:26

[[att]] is the old way of doing this so we need to continue supporting this as people will have updates with this format.

It seems parse_updatebody in functions.inc.php should still do this though isn't for some reason
User avatar (0000337)
paulh (administrator)
2008-12-13 10:46

In 3.32 we had

if (file_exists("{$CONFIG['attachment_fspath']}{$update->incidentid}/{$update->timestamp}"))
    {
        $attachment_webpath = "{$CONFIG['attachment_webpath']}{$update->incidentid}/{$update->timestamp}";
    }
    else
    {
        $attachment_webpath = "{$CONFIG['attachment_webpath']}updates/{$update->id}";
    }
    $updatebody = preg_replace("/\[\[att\]\](.*?)\[\[\/att\]\]/", "<a href = '{$attachment_webpath}/$1'>$1</a>", $updatebody);



I think we should still have this in as that parse_updatebody function I dont think is intended to do this (as it checkes if its longer than 490 chars and appends ...)
User avatar (0000349)
ivan (administrator)
2008-12-14 18:14

This isn't bbcode exactly, but I've added back the code that supports these old-style attachment links. The code does a file_exists() to check whether to run, it shouldn't be too expensive to leave that in and it is required to support all these old attachments.

svn r4472 in 3.41branch
needs porting to trunk
User avatar (0000398)
ivan (administrator)
2009-01-05 10:32

Ported to trunk as svn r4565

- Issue History
Date Modified Username Field Change
2008-12-12 16:05 paulh New Issue
2008-12-13 10:26 paulh Note Added: 0000336
2008-12-13 10:46 paulh Note Added: 0000337
2008-12-14 13:34 paulh Target Version => 3.41
2008-12-14 18:14 ivan Note Added: 0000349
2008-12-14 18:14 ivan Assigned To => ivan
2008-12-14 18:14 ivan Status new => resolved
2008-12-14 18:14 ivan Resolution open => fixed
2008-12-14 18:14 ivan Fixed in Version => 3.41
2008-12-14 18:14 ivan Tag Attached: needsporting
2009-01-05 10:32 ivan Note Added: 0000398
2009-01-05 10:32 ivan Tag Detached: needsporting
2010-03-04 17:38 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker