SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000370SiT!inbound emailpublic2009-01-07 13:112009-08-16 14:38
Reporternicdev 
Assigned Toivan 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.41 
Target Version3.50Fixed in Version3.50 
Summary0000370: Escaped characters in DB affects other sit functions.
DescriptionWhen escaped characters exist in the DB, then they can affect other SiT functions when they are imported from the DB later.
TagsNo tags attached.
Attached Filesjpg file icon error2_escapes.jpg [^] (67,773 bytes) 2009-01-13 08:58

- Relationships
related to 0000406closedivan Inbound email with ' in the email address - email is deleted and not imported to the holding queue 

-  Notes
User avatar (0000418)
nicdev (developer)
2009-01-07 13:13

example error in log:

"Application Warning [512] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'aaldeenshabsough@xxxxxx.com%'' at line 1 (in line 50 of file C:\wamp\www\sit\htdocs\review_incoming_updates.php)
Warning [2] mysql_fetch_row(): supplied argument is not a valid MySQL result resource (in line 51 of file C:\wamp\www\sit\htdocs\review_incoming_updates.php)
User avatar (0000482)
nicdev (developer)
2009-01-13 08:54

Found another one today:

Application Error [256]
MySQL Query Error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'un collaborateur

J\'attends l\'├ętude du contrat du client par Al' at line 1 in C:\wamp\www\sit\htdocs\incident\update.inc.php @ line 641
Backtrace:
C:\wamp\www\sit\htdocs\incident\update.inc.php @ line 641 trigger_error()
C:\wamp\www\sit\htdocs\update_incident.php @ line 30 include()

As the French use the "'" a lot this pops up now regularly.
User avatar (0000483)
nicdev (developer)
2009-01-13 08:59

Just added another, from yesterday seems to be all popping up when updating incidents
User avatar (0000486)
nicdev (developer)
2009-01-14 08:06

Hi We have found that after the new french translation file the issues are very prominent. for status updates i removed some "'" from the translations, and most have disappeared. We have 90% French users and it is creating havoc!

e.g. changing status from "active" (french = "Actif") to "Awaiting Customer Action" (French = "en attente d'action client"), then the script fails with the above mysql errors.
User avatar (0000929)
ivan (administrator)
2009-04-17 15:59

Have fixed the last of these, changing status with french language causes SQL error. Trunk svn r5330

In future could you log things like this as seperate bugs and relate them? easier to track that way. thanks.
User avatar (0000930)
ivan (administrator)
2009-04-17 16:04

This isn't an issue for the new inbox which will replace the holding queue for incoming emails in v3.50
User avatar (0001611)
ivan (administrator)
2009-08-16 14:38

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-01-07 13:11 nicdev New Issue
2009-01-07 13:13 nicdev Note Added: 0000418
2009-01-13 08:54 nicdev Note Added: 0000482
2009-01-13 08:58 nicdev File Added: error2_escapes.jpg
2009-01-13 08:59 nicdev Note Added: 0000483
2009-01-14 08:06 nicdev Note Added: 0000486
2009-01-14 08:07 nicdev Severity major => crash
2009-03-05 13:55 ivan Relationship added related to 0000406
2009-04-17 15:59 ivan Note Added: 0000929
2009-04-17 16:04 ivan Note Added: 0000930
2009-04-17 16:04 ivan Assigned To => ivan
2009-04-17 16:04 ivan Status new => resolved
2009-04-17 16:04 ivan Resolution open => fixed
2009-04-17 16:04 ivan Fixed in Version => Current SVN
2009-04-17 16:04 ivan Target Version => 3.50
2009-08-16 13:17 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:38 ivan Note Added: 0001611
2009-08-16 14:38 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker