SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000375SiT!searchpublic2009-01-08 14:152009-08-16 14:39
Reporterpaulh 
Assigned Tokieran 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.41 
Target Version3.50Fixed in Version3.50 
Summary0000375: Searching for a number other than an incident number doesn't work
DescriptionIf you search for an number (e.g. 11 digit Novell SR number) returns just a the headers and footers

Seems to be search.php:92 which does if (is_numeric($q)) rather than something more complex
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000440)
ivan (administrator)
2009-01-08 14:23

Hmm that was by design, but maybe we should be a bit cleverer
User avatar (0000441)
paulh (administrator)
2009-01-08 18:22

Probably should be as this prevents us from searching for Novell incident numbers, any error code etc

We should also print a message to say no results found rather than just display the header and footer as at the moment it looks like its broke
User avatar (0000715)
ivan (administrator)
2009-03-05 11:40

You can search for a number that isn't an incident number by enclosing it in quotes. see the updated search docs at http://sitracker.org/wiki/Search [^]
User avatar (0000718)
kieran (administrator)
2009-03-05 13:21

The problem is what we define as an incident number. Most people start at 1, we started at 20000, some companies might start with an eleven digit number. Until we sort escalations we have to assume an integer is an incident number really.
User avatar (0000719)
ivan (administrator)
2009-03-05 13:30

Gonna close this one, as Kieran points out, we can't assume anything about incident numbers. There's a valid way to search as I've now documented so I don't think a code change is needed at least until we offer the ability to have custom incident number formats (if we do that)
User avatar (0000736)
paulh (administrator)
2009-03-06 19:56

If this is the tack we're going to take then I think the search screen should inform the user that if they dont want to search for an incident number then they should enclose it in "

Whilst this might be in the documentation people just dont read docs
User avatar (0000752)
ivan (administrator)
2009-03-07 15:21

Thinking about this, perhaps the quick search on the toolbar and the search page itself should have different default behaviour. If you actually go to the search page you probably don't want to jump to an incident...

Something to make it clearer couldn't hurt anyway, I'll have look at this before 3.50.
User avatar (0001208)
kieran (administrator)
2009-06-13 16:29

Fixed in trunk r5455.

If the query is an incident number, use that otherwise assume a search term. Seems to be decent enough until escalations.
User avatar (0001663)
ivan (administrator)
2009-08-16 14:39

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-01-08 14:15 paulh New Issue
2009-01-08 14:23 ivan Note Added: 0000440
2009-01-08 18:22 paulh Note Added: 0000441
2009-01-09 14:20 ivan Status new => confirmed
2009-03-05 11:40 ivan Note Added: 0000715
2009-03-05 13:21 kieran Note Added: 0000718
2009-03-05 13:30 ivan Note Added: 0000719
2009-03-05 13:30 ivan Status confirmed => closed
2009-03-05 13:30 ivan Resolution open => won't fix
2009-03-06 19:56 paulh Note Added: 0000736
2009-03-06 19:56 paulh Status closed => new
2009-03-06 19:56 paulh Resolution won't fix => open
2009-03-07 15:21 ivan Note Added: 0000752
2009-03-07 15:21 ivan Assigned To => ivan
2009-03-07 15:21 ivan Status new => assigned
2009-03-07 15:21 ivan Target Version => 3.50
2009-06-13 16:29 kieran Note Added: 0001208
2009-06-13 16:29 kieran Assigned To ivan => kieran
2009-06-13 16:29 kieran Status assigned => resolved
2009-06-13 16:29 kieran Resolution open => fixed
2009-06-13 16:29 kieran Fixed in Version => Current SVN
2009-08-16 13:16 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:39 ivan Note Added: 0001663
2009-08-16 14:39 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker