SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000533SiT!outbound emailpublic2009-03-02 08:412009-08-16 14:40
Reporternicdev 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.50Fixed in Version3.50 
Summary0000533: When sending mail the mail body gets sent as an attachment
DescriptionWhen we send a mail from the incident window, the mail body gets sent as an attachment (eg "ATT81377.txt), and the rest of the mail is empty.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000689)
ivan (administrator)
2009-03-04 15:37

Thanks for the bug report, however I can't repro this. Can you post exact steps required to reproduce it, including the version of SiT you are running (3.45 final?) and the name and version of the email client you are using to receive the email.

Thanks,

Ivan
User avatar (0000711)
nicdev (developer)
2009-03-05 08:24

Hi Ivan,

This is strange as it is always the sale for us. We are using the release of 3.45 i installed over the weekend. I have sent a test mail to you directly from the tracker, and i have also tested it with both my hotmail and M$ echange client. In hotmail i get a blank as well as with my M$ echange account. I have the logs of the sendamail debug file if you want to see what gets sent.

Thanks
User avatar (0000712)
nicdev (developer)
2009-03-05 08:45

Hi Ivan,

It is interesting to note that the automated emails are not affected bu this...
User avatar (0000713)
kieran (administrator)
2009-03-05 09:38

If the automated emails aren't affected it must be the change to sending all mails as mime emails as triggers don't do this.
User avatar (0000714)
ivan (administrator)
2009-03-05 10:07

Hmm gonna have to try harder to reproduce this then. The mail I received from Nicdev (thanks btw!) was indeed blank with an attachment.
User avatar (0000717)
nicdev (developer)
2009-03-05 12:50

Hi Ivan,

I sent you the senmail debug log to show you what gets sent to the smtp server ..; hope it helps..

Cheers
User avatar (0000807)
ivan (administrator)
2009-03-24 17:59

Scott (smelvin) posted on our forum to say he'd found a fix for this:

http://sitracker.org/forum/viewtopic.php?f=4&t=1416750 [^]

We had text-plain as the mime type rather than text/plain!

I hope this is all that was wrong, would be rather nice if it really was as easy as that to fix. I've committed the correct mime type to trunk as r5259
User avatar (0000808)
ivan (administrator)
2009-03-24 17:59

Needs testing
User avatar (0000835)
nicdev (developer)
2009-03-26 09:51

Tested after the modification suggested by Scott, and it works for us now..
User avatar (0000852)
ivan (administrator)
2009-03-28 17:05

Tried sending to exchange and outlook and this works fine now. Thanks to everybody who helped with this one!
User avatar (0001754)
ivan (administrator)
2009-08-16 14:40

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-03-02 08:41 nicdev New Issue
2009-03-04 15:37 ivan Note Added: 0000689
2009-03-04 15:37 ivan Reproducibility always => unable to reproduce
2009-03-04 15:37 ivan Status new => feedback
2009-03-05 08:24 nicdev Note Added: 0000711
2009-03-05 08:45 nicdev Note Added: 0000712
2009-03-05 09:38 kieran Note Added: 0000713
2009-03-05 10:07 ivan Note Added: 0000714
2009-03-05 12:50 nicdev Note Added: 0000717
2009-03-24 17:59 ivan Note Added: 0000807
2009-03-24 17:59 ivan Reproducibility unable to reproduce => have not tried
2009-03-24 17:59 ivan Note Added: 0000808
2009-03-24 17:59 ivan Resolution open => fixed
2009-03-24 17:59 ivan Fixed in Version => Current SVN
2009-03-24 18:00 ivan Assigned To => ivan
2009-03-26 09:51 nicdev Note Added: 0000835
2009-03-27 10:25 ivan Status feedback => assigned
2009-03-28 17:05 ivan Note Added: 0000852
2009-03-28 17:05 ivan Status assigned => resolved
2009-08-15 21:31 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:40 ivan Note Added: 0001754
2009-08-16 14:40 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker