SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000583SiT!i18npublic2009-03-25 11:422009-08-16 14:39
ReporterTomse 
Assigned Tokieran 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.60 LTSFixed in Version3.50 
Summary0000583: 3.50 svn5217 - Trigger action static language
Descriptionon the triggers page --> in the "Action" column

Create a notice based on

is static

The column Triggers texts are static

TagsNo tags attached.
Attached Files

- Relationships
related to 0000450resolvedkieran Contextual trigger rule pages 

-  Notes
User avatar (0001091)
ivan (administrator)
2009-05-21 11:25

Sorry, going to bump this one to 3.60, it's not very simple to fix as the sentences are built up dynamically which doesn't lend itself to i18n. I don't want to delay the 3.50 release with this one.
User avatar (0001211)
ivan (administrator)
2009-06-15 15:30
edited on: 2009-06-15 15:31

Not sure of the correct way to i18n the help descriptions of triggers.

trigger_description() has:

if (isset($GLOBALS[$triggervar['description']]))
{
    $html .= $GLOBALS[$triggervar['description']];
}
else
{
    $html .= $triggervar['description'];
}


yet the trigger definitions in triggertypes.inc.php have:

'description' => $strTriggerContactResetPasswordDesc,

Shouldn't that be?

'description' => 'strTriggerContactResetPasswordDesc',


Not really sure what was intended here, Kieran can you clarify?

User avatar (0001213)
kieran (administrator)
2009-06-15 18:32

I think you're right. I also thought that had been fixed, perhaps it got lost somewhere.
User avatar (0001216)
kieran (administrator)
2009-06-16 14:55

Fixed in trunk r5462.
User avatar (0001657)
ivan (administrator)
2009-08-16 14:39

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-03-25 11:42 Tomse New Issue
2009-03-25 11:45 ivan Status new => confirmed
2009-03-25 11:45 ivan Target Version => 3.50
2009-03-25 12:33 Tomse Summary 3.50 svn5217 => 3.50 svn5217 - Static language
2009-03-25 12:33 Tomse Description Updated
2009-03-28 22:23 ivan Relationship added related to 0000450
2009-05-21 11:25 ivan Note Added: 0001091
2009-05-21 11:25 ivan Target Version 3.50 => 3.60
2009-05-21 11:25 ivan Summary 3.50 svn5217 - Static language => 3.50 svn5217 - Trigger action static language
2009-06-15 15:28 ivan Status confirmed => assigned
2009-06-15 15:28 ivan Assigned To => kieran
2009-06-15 15:30 ivan Note Added: 0001211
2009-06-15 15:31 ivan Note Edited: 0001211
2009-06-15 18:32 kieran Note Added: 0001213
2009-06-16 14:55 kieran Note Added: 0001216
2009-06-16 14:55 kieran Status assigned => resolved
2009-06-16 14:55 kieran Fixed in Version => Current SVN
2009-06-16 14:55 kieran Resolution open => fixed
2009-08-16 13:16 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:39 ivan Note Added: 0001657
2009-08-16 14:39 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker