SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000628SiT!otherpublic2009-04-02 11:592009-08-16 14:38
ReporterTomse 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.50Fixed in Version3.50 
Summary0000628: autocomplete breaks with non-english characters
Descriptionfor example trying to autocomplete the name Søren shows S& oslash;ren in the autocomplete suggestions.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000470closedivan Drafts do not save correctly 

-  Notes
User avatar (0000886)
ivan (administrator)
2009-04-02 18:03

This is caused by the way we call cleanvar() to sanitize variables. The default is to run htmlentities() which makes the ø into "& oslash;"

if we call cleanvar() with the third param false this fixes the problem.

$name = cleanvar($_POST['name'], TRUE, FALSE);

I'm not sure now whether to change the default for cleanvar()... going to do some investigation first.
User avatar (0001068)
ivan (administrator)
2009-05-15 15:08

Not sure which commit actually fixed this, but I did some work on it a few weeks ago and testing it now it seems ok. works in svn trunkk r5378
User avatar (0001584)
ivan (administrator)
2009-08-16 14:38

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-04-02 11:59 ivan New Issue
2009-04-02 11:59 ivan Status new => assigned
2009-04-02 11:59 ivan Assigned To => ivan
2009-04-02 12:30 ivan Reporter ivan => Tomse
2009-04-02 12:30 ivan Description Updated
2009-04-02 18:03 ivan Note Added: 0000886
2009-04-02 18:04 ivan Description Updated
2009-04-03 10:05 ivan Relationship added related to 0000470
2009-05-15 15:08 ivan Note Added: 0001068
2009-05-15 15:08 ivan Status assigned => resolved
2009-05-15 15:08 ivan Resolution open => fixed
2009-05-15 15:08 ivan Fixed in Version => Current SVN
2009-08-16 13:17 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:38 ivan Note Added: 0001584
2009-08-16 14:38 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker