SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000641SiT!inbound emailpublic2009-04-09 14:492009-08-16 14:38
Reporternicdev 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.50Fixed in Version3.50 
Summary0000641: Pictures inside the emailbody are not imported as in previous vesions
DescriptionIn the past a picture in the mail body was imported with the email as an attachment, but today it is removed and there is no indication that there was a picture in the mail before..

We rely a lot on screenshots for customers to explain the issues, but the engineer sometimes wastes a lot of time to ask for screenshots that were already sent in the first place, and some customers are a "bit" annoyed..

Is it a function that was removed or did it disappear as a bug?

Thanks
TagsNo tags attached.
Attached Files

- Relationships
related to 0000932closed Pictures in the mail body are not imported .. 

-  Notes
User avatar (0000900)
ivan (administrator)
2009-04-09 15:20
edited on: 2009-04-09 15:21

Hi Nicdev,

All pictures should be treated as attachments just as in past releases, I'm not aware of any problem with this and I've received hundreds of pictures (and yes they're usually screenshots ;) ) without any problem.

I think it's more likely to be something to with another exotic mail format, can you forward one of them to my test account, click here for the address

http://mailhide.recaptcha.net/d?k=01Ub100cAswIwuOl3kRduPuA==&c=ZbOh4jF6pacpAMQaLkejiw8l3pRdrVJap6vatbg7RXE= [^]

Thanks,

Ivan
(Updated: wrong url the first time, whoops)

User avatar (0000911)
nicdev (developer)
2009-04-10 15:43

Hi Ivan,

I have spent the better part of the day trying to figure this one out, but i cannot..

I did find however that it stopped working the moment we changed to the new mime_parser_inc_.php script ..

In the sit.log i can see it finds the image but it does not put it into the directory "updates". I found in the beginning that we had issues with "read only" rights, but after solving that the problem remains..

i am emailing you a part of the sit.log to see what i mean...

Best
User avatar (0000917)
ivan (administrator)
2009-04-16 11:52

I can repro this with the email that you've sent me. I get this warning in the logs:

009-04-16T11:49:38+01:00 auto.php ERROR: Warning mb_convert_encoding(): Illegal character encoding specified in /home/ivan/src/sit/trunk/inboundemail.php at line 170
2009-04-16T11:49:38+01:00 auto.php Converted 'from header' encoding from to UTF-8

It does look like it might be related, but not totally sure at the moment.
User avatar (0000918)
ivan (administrator)
2009-04-16 16:03

This is fixed in svn trunk r5326.
The mb_convert_encoding() warning turned out to be unrelated but that now is fixed also.

The problem was that some emails are sent as mime multipart/related which we weren't handling. multipart/related emails are parsed differently and we were looking in the wrong place for the attached picture. SiT now treats multipart/related and multipart/alternative attachments just the same.
User avatar (0001580)
ivan (administrator)
2009-08-16 14:38

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-04-09 14:49 nicdev New Issue
2009-04-09 15:20 ivan Note Added: 0000900
2009-04-09 15:20 ivan Status new => feedback
2009-04-09 15:21 ivan Note Edited: 0000900
2009-04-10 15:43 nicdev Note Added: 0000911
2009-04-16 11:52 ivan Note Added: 0000917
2009-04-16 11:52 ivan Status feedback => confirmed
2009-04-16 12:04 ivan Status confirmed => assigned
2009-04-16 12:04 ivan Assigned To => ivan
2009-04-16 16:03 ivan Note Added: 0000918
2009-04-16 16:03 ivan Status assigned => resolved
2009-04-16 16:03 ivan Resolution open => fixed
2009-04-16 16:03 ivan Fixed in Version => Current SVN
2009-04-16 16:03 ivan Target Version => 3.50
2009-08-16 13:17 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:38 ivan Note Added: 0001580
2009-08-16 14:38 ivan Status resolved => closed
2009-09-10 13:19 ivan Relationship added related to 0000932


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker