SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000645SiT!otherpublic2009-04-15 10:502009-08-16 14:40
Reporterivan 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.50Fixed in Version3.50 
Summary0000645: Draft error with long email
DescriptionA particularly long email was written and this caused an error relating to drafts:

2009-04-15T10:34:46+01:00 /webtrack/incident_email.php Application Error [256] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server versio
n for the right syntax to use near '\r\n\r\n414 Request-URI Too Large\r\n\r\nRequest-URI Too Large\r\nThe requested ' at line 1 (in line 852 of file /var/webtrack/incident_email.p
hp)


The dump below the error showed that draftid was set to an error message instead of a number:


           [draftid] =>

414 Request-URI Too Large

Request-URI Too Large
The requested URL's length exceeds the capacity
limit for this server.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000932)
paulh (administrator)
2009-04-17 19:44

Cheers Ivan, we're using GET need to change this to POST

http://www.openjs.com/articles/ajax_xmlhttp_using_post.php [^] covers this
User avatar (0000934)
paulh (administrator)
2009-04-18 12:30

Hi Ivan, I belive trunk.r5331 resolves ths by switching from GET to POST, it does still suffer from a problem with MASSIVE emails though thats due to the max size of post data which isn't something we can really get around short of sending small chunks of data and then reassembling them server side which I don't think is worth it at the moment as you'd have to send a very long email of which SiT! would then fail to send as well.
User avatar (0000935)
ivan (administrator)
2009-04-18 13:03

Cool, thanks. Do you know what size fails? I would imagine it's pretty damn big?
User avatar (0000936)
paulh (administrator)
2009-04-18 13:17

It fails at 64k
User avatar (0000942)
ivan (administrator)
2009-04-20 11:23

svn trunk r5331 by paul fixes this for me. marked resolved. Doubt we'll get people writing more than 64kb of email in one go and if they do... well they should feel sorry for the addressee having to read all that and perhaps consider splitting their message into two or more separate emails.
User avatar (0001743)
ivan (administrator)
2009-08-16 14:40

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-04-15 10:50 ivan New Issue
2009-04-15 10:50 ivan Status new => assigned
2009-04-15 10:50 ivan Assigned To => paulh
2009-04-17 19:44 paulh Note Added: 0000932
2009-04-18 12:30 paulh Note Added: 0000934
2009-04-18 12:30 paulh Assigned To paulh => ivan
2009-04-18 12:30 paulh Status assigned => feedback
2009-04-18 13:03 ivan Note Added: 0000935
2009-04-18 13:17 paulh Note Added: 0000936
2009-04-20 11:23 ivan Note Added: 0000942
2009-04-20 11:23 ivan Assigned To ivan => paulh
2009-04-20 11:23 ivan Status feedback => resolved
2009-04-20 11:23 ivan Resolution open => fixed
2009-04-20 11:23 ivan Fixed in Version => Current SVN
2009-08-15 21:31 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:40 ivan Note Added: 0001743
2009-08-16 14:40 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker