SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000659SiT!i18npublic2009-04-22 10:202009-08-16 14:38
Reporternicdev 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSOS Version
Product Version3.45 
Target Version3.50Fixed in Version3.50 
Summary0000659: Incorrect internationalisation saved in DB
DescriptionWhen i look at the sit.log i get a lot of errors:

2009-04-22T09:25:17+02:00 /sit/ajaxdata.php Warning [2] include(C:\wamp\www\sit\i18n\defau.inc.php) [function.include]: failed to open stream: No such file or directory (in line 49 of file C:\wamp\www\sit\lib\auth.inc.php)

When i look in the Db at the users table, i see a user (just one) with "defau" in his the column "i18n", that must have been there since version 3.41. When i change this manually to "fr-FR" the errors seems to disappear, but when he logs out, and back in again, it replaces the "fr_FR" with "defau" again, and the errors restart.

If he chooses the fr-FR file on the dropdown at login time, it writes"/i18n" to the DB which causes even more errors..

On the same issue, when i go to the config page to select the default i18n the block shows "ca-ES" as the default language, but in my config.inc and the default.inc it is specified as "en-GB" ???

If i change it here, to "en-GB", it adds an entry to the config table in the DB but it writes "//i18n//en-GB", which messes things up again, and in fact after this the config page still shows "ca-ES".
TagsNo tags attached.
Attached Filesjpg file icon i18n.jpg [^] (259,737 bytes) 2009-04-22 13:58

- Relationships
has duplicate 0000660closed Wrong function i18n_filename_to_code in string.inc.php (Win32) 

-  Notes
User avatar (0000955)
nicdev (developer)
2009-04-22 10:43

Hi Ivan,

I had no setting in my config.inc before, but now i have added:

// Default Internationalisation tag (rfc4646/rfc4647/ISO 639 code), note the corresponding i18n file must exist in includes/i18n before you can use it
$CONFIG['default_i18n'] = 'en-GB';

directly in my config file, and also i have deleted the "//i18n//en-GB", from the db config table because it caused even more issues.

Language config = en-GB (set in config.inc -see not above about the config page not displaying correctly)
Our chosen languages to display = ALL, but nothing is written to the DB
Language chosen in the users profile = fr-FR according to the db table "users" but when i open the user's config page it show "default" which is not true.

Let me know if you need further info

Cheers
User avatar (0000956)
nicdev (developer)
2009-04-22 13:57

Hi Ivan,

Ok for now the errors have stopped. I removed the i18n entries in the config table in the Db, and i added,

$CONFIG['default_i18n'] = 'en-GB';

to my config.inc file.

I had the user (french guy) logout of SiT and completely cleared his cache, cookies etc. and it seems now the most is solved.

What still remains is the following:

In the language lists not showing correctly, (see screenshot), and the following that keeps popping up in the sit.log:

2009-04-22T14:30:34+02:00 /sit/ajaxdata.php Warning [2] htmlentities() [function.htmlentities]: Invalid multibyte sequence in argument (in line 239 of file C:\wamp\www\sit\lib\base.inc.php)
User avatar (0000957)
ivan (administrator)
2009-04-22 16:48

This is fixed in svn r5344

We were using a hardcoded path separator when generating the list of language codes from the language files
User avatar (0001576)
ivan (administrator)
2009-08-16 14:38

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-04-22 10:20 nicdev New Issue
2009-04-22 10:43 nicdev Note Added: 0000955
2009-04-22 13:57 nicdev Note Added: 0000956
2009-04-22 13:58 nicdev File Added: i18n.jpg
2009-04-22 16:48 ivan Note Added: 0000957
2009-04-22 16:48 ivan Assigned To => ivan
2009-04-22 16:48 ivan Status new => resolved
2009-04-22 16:48 ivan Resolution open => fixed
2009-04-22 16:48 ivan Platform => Windows
2009-04-22 16:48 ivan Fixed in Version => Current SVN
2009-04-22 16:48 ivan Target Version => 3.50
2009-04-23 09:56 ivan Relationship added has duplicate 0000660
2009-08-16 13:17 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:38 ivan Note Added: 0001576
2009-08-16 14:38 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker