SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000668SiT!holidayspublic2009-04-27 21:062009-08-16 14:40
Reporterpaulh 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.50Fixed in Version3.50 
Summary0000668: Crash on approve all
DescriptionWhen you have more than one holiday and click "approve all" you get the following crash:

Application Warning [512]
Empty TO address in email in /home/paulh/sit/lib/functions.inc.php @ line 2689
Backtrace:
/home/paulh/sit/lib/functions.inc.php @ line 2689 trigger_error()
/home/paulh/sit/holiday_approve.php @ line 74 send_email()

Warning [2]
Cannot modify header information - headers already sent by (output started at /home/paulh/sit/lib/functions.inc.php:2255) in /home/paulh/sit/holiday_approve.php @ line 83
Backtrace:
/home/paulh/sit/holiday_approve.php @ line 83 header()

This warning may be caused by a problem that occurred before the page was displayed, or sometimes by a syntax error or extra whitespace in your config file.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0001064)
ivan (administrator)
2009-05-15 13:48

Worked around this error by disabling sending email when approving all, this needs to use triggers anyway, for now we just hide the error really.

svn trunk r5377
User avatar (0001739)
ivan (administrator)
2009-08-16 14:40

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-04-27 21:06 paulh New Issue
2009-05-15 13:48 ivan Note Added: 0001064
2009-05-15 13:48 ivan Assigned To => ivan
2009-05-15 13:48 ivan Status new => resolved
2009-05-15 13:48 ivan Resolution open => fixed
2009-05-15 13:48 ivan Fixed in Version => Current SVN
2009-08-15 21:31 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:40 ivan Note Added: 0001739
2009-08-16 14:40 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker