SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000673SiT!triggerspublic2009-04-30 08:162009-08-16 14:40
Reporternicdev 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.50Fixed in Version3.50 
Summary0000673: Trigger "TRIGGER_WAITING_HELD_EMAIL" logic
DescriptionWhen i program a notice base on "TRIGGER_WAITING_HELD_EMAIL", and i specify for instance {holdinhmins}==5, the notice should pop up whenever a mail is in the queue for longer than 5 minutes - This works correctly...

BUT

This trigger fires everytime the Scheduler (auto.php) runs "CheckWaitingEmail" which is every 3 minutes, and thus i get the message "There is a new mail in the holding queue.. repeated every 3 minutes for the same email ... Thus i had 456 notices to clear this morning because i was out of the office yesterday...

I believe this trigger should maybe check in the notices DB if the notice has been created for the user and if so not to repeat it ...

The engineer needs to know about it, but not 400 times ;-) .... (or maybe he should >) ...

I am not sure if this was the intended way for it to waork in which case we need to change this to a feature request..
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0001005)
kieran (administrator)
2009-04-30 10:43
edited on: 2009-04-30 10:45

I'm not sure if that's your real rule or just off your head but looking at the code it uses 'minswaiting' not 'holdingmins'.

Even so, you're right, the logic is off. Your rule says =5, it should be >5 and we should only check in the code if it's more than {minswaiting} + $CHECKINTERVAL then you'll only ever get one notification.

User avatar (0001006)
nicdev (developer)
2009-04-30 11:23

Thanks Kieran,

I agree, and i have been checking the code after the bug report, and i come to the same conclusion.

If you can post a diff file or change it in svn, i will update our local 3.45 installation, or if you are too busy, i will hold off until 3.46 to impliment such notifications.

Thanks
Cheers
User avatar (0001080)
ivan (administrator)
2009-05-19 17:49

As of 3.45 it's not possible to use >= in trigger rules. I've added more operators to the trigger rules toolbar in trunk svn r5392 which allows creating of a sensible rule for this trigger.
User avatar (0001738)
ivan (administrator)
2009-08-16 14:40

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-04-30 08:16 nicdev New Issue
2009-04-30 10:43 kieran Note Added: 0001005
2009-04-30 10:45 kieran Note Edited: 0001005
2009-04-30 11:23 nicdev Note Added: 0001006
2009-05-19 17:49 ivan Note Added: 0001080
2009-05-19 17:49 ivan Assigned To => ivan
2009-05-19 17:49 ivan Status new => resolved
2009-05-19 17:49 ivan Resolution open => fixed
2009-05-19 17:49 ivan Fixed in Version => Current SVN
2009-08-15 21:31 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:40 ivan Note Added: 0001738
2009-08-16 14:40 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker