SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000717SiT!triggerspublic2009-06-04 08:282009-08-16 14:40
ReporterBonkie 
Assigned Tokieran 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformApple iMacOSMac OSX OS Version10.5
Product Version 
Target Version3.50Fixed in Version3.50 
Summary0000717: Bug in auto.php considering the 'Mark for Closure' items in the support system
DescriptionWhen having a item on 'Marked for Closure' in the SiT! system and the time has been past it wont close the item at all. So we have fixed it with a temporary addition to the auto.php.

Our addition starts at line 58 of auto.php

Addition:
 
///// SOMETIMES THERE IS JUST AN LITTLE UPDATE STATEMENT NEEDED :-)
$SQL = "UPDATE `{$dbIncidents}` SET lastupdated='{$now}', ";
$SQL .= "closed='{$now}', status='".STATUS_CLOSED."', closingstatus='4', ";
$SQL .= "timeofnextaction='0' WHERE status='".STATUS_CLOSING."' ";
$SQL .= "AND (({$now} - lastupdated) > '{$closure_delay}') ";
$SQL .= "AND (timeofnextaction='0' OR timeofnextaction<='{$now}')";

$doQuery = mysql_query($SQL) or die(mysql_error());
//////////////////////////////// END UPDATE ////////////////////////////////


Hopefully you guys can fix this in a correct way or just use our solution (which is also correct)
Steps To ReproduceJust run auto.php and see if it closes (i bet it wont)
TagsNo tags attached.
Attached Files? file icon auto.php [^] (31,768 bytes) 2009-06-04 08:28

- Relationships

-  Notes
User avatar (0001167)
ivan (administrator)
2009-06-05 10:49

Thanks Bonkie, looks like some recent code for billing might have removed the important bit of code that made that work. :-/
User avatar (0001196)
kieran (administrator)
2009-06-13 09:55

Fixed in trunk r5450. Thanks for the patch!
User avatar (0001729)
ivan (administrator)
2009-08-16 14:40

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-06-04 08:28 Bonkie New Issue
2009-06-04 08:28 Bonkie File Added: auto.php
2009-06-05 10:49 ivan Note Added: 0001167
2009-06-05 10:49 ivan Status new => confirmed
2009-06-13 09:55 kieran Note Added: 0001196
2009-06-13 09:55 kieran Assigned To => kieran
2009-06-13 09:55 kieran Status confirmed => resolved
2009-06-13 09:55 kieran Resolution open => fixed
2009-06-13 09:55 kieran Fixed in Version => Current SVN
2009-08-15 21:31 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:40 ivan Note Added: 0001729
2009-08-16 14:40 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker