SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000768SiT!LDAPpublic2009-07-11 12:062009-08-16 14:40
Reporterpaulh 
Assigned Topaulh 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.50Fixed in Version3.50 
Summary0000768: make caching passwords configurable
DescriptionPaul,

2009/7/11 Paul Heaney <paulheaney@users.sourceforge.net>:
> > The MD5 of the password is always cached though whether a user can
> > authenticate or not with it is configurable, it would be easy to prevent the
> > caching of passwords if you think it would be worth it?
> >
> > The reason I did this is that you probably only want to enable
> > authentication against cached passwords if you know your directory will be
> > down for a while in which case you wont have time to cache them all, though
> > we could make this a separate config option.
Ah I understand now, and that does make sense. I wonder though if
some people might be worried about the password caching, even if it's
is MD5 hashed, there is a risk involved with it. Perhaps another
option is good.

Ivan
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0001301)
paulh (administrator)
2009-07-12 15:28

trunk r5514 adds this
User avatar (0001722)
ivan (administrator)
2009-08-16 14:40

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-07-11 12:06 paulh New Issue
2009-07-11 12:06 paulh Status new => assigned
2009-07-11 12:06 paulh Assigned To => paulh
2009-07-12 15:28 paulh Note Added: 0001301
2009-07-12 15:28 paulh Status assigned => resolved
2009-07-12 15:28 paulh Resolution open => fixed
2009-07-12 15:28 paulh Fixed in Version => Current SVN
2009-08-15 21:31 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:40 ivan Note Added: 0001722
2009-08-16 14:40 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker