SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000798SiT!i18npublic2009-07-23 09:162009-08-16 14:39
Reportersancho78rus 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.50Fixed in Version3.50 
Summary0000798: cannot find any contact by clicking on its first letter (in russian)
DescriptionFirst letter search of contacts dont work in rusian.
when i click on letter 'T' (T in russian) there must be contact. but there is nothing. I tried to click on first letter on name and lastname - nothing.
if click 'show all' - its ok, but we have over 1000 contacts and its not comfortable.
version is 3.50
TagsNo tags attached.
Attached Files

- Relationships
related to 0000910closedivan Cannot find contact by first letter 

-  Notes
User avatar (0001381)
ivan (administrator)
2009-07-23 17:45

thanks for the bug report.

This seems to be a problem with our alpha_index() function and the way we're urlencoding/decoding.
User avatar (0001404)
kieran (administrator)
2009-07-26 13:10

Mentioned in IRC by Ivan but it seems to be a problem with MySQL's strict tables modes, it works it it's turned off.
User avatar (0001509)
ivan (administrator)
2009-08-05 15:03

With the Danish language I can search for "Å" and get no results but search for "A" and get results that begin "Å"
User avatar (0001511)
ivan (administrator)
2009-08-05 15:46

Used LIKE with a wildcard instead of a search using SUBSTRING() and it works just fine, I suspect there is something wrong with SUBSTRING() in MySQL. Maybe only with certain SQL-MODES, I couldn't seem to reproduce it reliably.

Fix in trunk r5738
User avatar (0001693)
ivan (administrator)
2009-08-16 14:39

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-07-23 09:16 sancho78rus New Issue
2009-07-23 17:45 ivan Note Added: 0001381
2009-07-23 17:45 ivan Status new => confirmed
2009-07-25 15:07 ivan Target Version => 3.50
2009-07-26 13:10 kieran Note Added: 0001404
2009-07-27 11:53 ivan Status confirmed => assigned
2009-07-27 11:53 ivan Assigned To => ivan
2009-08-05 15:03 ivan Note Added: 0001509
2009-08-05 15:46 ivan Note Added: 0001511
2009-08-05 15:46 ivan Status assigned => resolved
2009-08-05 15:46 ivan Resolution open => fixed
2009-08-05 15:46 ivan Fixed in Version => Current SVN
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:39 ivan Note Added: 0001693
2009-08-16 14:39 ivan Status resolved => closed
2009-08-27 10:04 ivan Relationship added related to 0000910


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker